{"answers":{"affected":"2 open source packages ship an affected version, including leantime/leantime.","exploited":"There is no known exploitation of GHSA-f679-254h-qhvj in the wild and no public exploit code.","fix":"Upgrade leantime/leantime to 3.3 or later.","what":"GHSA-f679-254h-qhvj is a cross-site scripting vulnerability in leantime/leantime, published on 21 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-f679-254h-qhvj and fix it if it is affected.\n\nWhat it is: GHSA-f679-254h-qhvj is a cross-site scripting vulnerability in leantime/leantime, published on 21 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-f679-254h-qhvj in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- leantime/leantime (Packagist): affected all versions; fixed in 3.3\n- leantime/leantime (Packagist): affected all versions; fixed in 3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-f679-254h-qhvj/ (Markdown: https://insights.sbomify.com/GHSA-f679-254h-qhvj/index.md)","id":"GHSA-f679-254h-qhvj","markdown":"https://insights.sbomify.com/GHSA-f679-254h-qhvj/index.md","name":"GHSA-f679-254h-qhvj","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Leantime project management","requires_auth":"low_privilege","summary":"An attacker can inject malicious scripts into To-Do titles, potentially compromising user sessions or data in Leantime.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\nThere is a cross-site scripting vulnerability on To-Do that affects a title field of a To-Do.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Leantime allows Cross-Site Scripting (XSS)","id":"GHSA-f679-254h-qhvj","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["3.3"],"introduced":["0"],"last_affected":[],"package":"leantime/leantime","purl":null,"source":"GHSA-f679-254h-qhvj"},{"ecosystem":"Packagist","fixed":["3.3"],"introduced":["0"],"last_affected":[],"package":"leantime/leantime","purl":"pkg:composer/leantime/leantime","source":"GHSA-f679-254h-qhvj"}],"products":null,"published":"2025-02-21","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can inject malicious scripts into To-Do titles, potentially compromising user sessions or data in Leantime.","url":"https://insights.sbomify.com/GHSA-f679-254h-qhvj/"}