{"answers":{"affected":"3 open source packages ship an affected version, including hyper.","exploited":"There is no known exploitation of GHSA-f67m-9j94-qv9j in the wild and no public exploit code.","fix":"Upgrade hyper to 0.14.12 or later.","what":"GHSA-f67m-9j94-qv9j is a memory corruption vulnerability in hyper, published on 10 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-f67m-9j94-qv9j and fix it if it is affected.\n\nWhat it is: GHSA-f67m-9j94-qv9j is a memory corruption vulnerability in hyper, published on 10 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-f67m-9j94-qv9j in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hyper (crates.io): affected all versions; fixed in 0.14.12\n- hyper (crates.io): affected all versions; fixed in 0.14.12\n- hyper (crates.io): affected from 0.0.0-0; fixed in 0.14.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-f67m-9j94-qv9j/ (Markdown: https://insights.sbomify.com/GHSA-f67m-9j94-qv9j/index.md)","id":"GHSA-f67m-9j94-qv9j","markdown":"https://insights.sbomify.com/GHSA-f67m-9j94-qv9j/index.md","name":"GHSA-f67m-9j94-qv9j","record":{"aliases":["RUSTSEC-2022-0022"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust HTTP parser","requires_auth":"none","summary":"An attacker can trigger memory corruption in the HTTP parser by sending crafted requests, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Affected versions of this crate called `mem::uninitialized()` in the HTTP1 parser to create values of type `httparse::Header` (from the `httparse` crate).\nThis is unsound, since `Header` contains references and thus must be non-null.\n \nThe flaw was corrected by avoiding the use of `mem::uninitialized()`, using `MaybeUninit` instead.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Parser creates invalid uninitialized value","id":"GHSA-f67m-9j94-qv9j","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2022"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.14.12"],"introduced":["0"],"last_affected":[],"package":"hyper","purl":null,"source":"GHSA-f67m-9j94-qv9j"},{"ecosystem":"crates.io","fixed":["0.14.12"],"introduced":["0"],"last_affected":[],"package":"hyper","purl":"pkg:cargo/hyper","source":"GHSA-f67m-9j94-qv9j"},{"ecosystem":"crates.io","fixed":["0.14.12"],"introduced":["0.0.0-0"],"last_affected":[],"package":"hyper","purl":"pkg:cargo/hyper","source":"RUSTSEC-2022-0022"}],"products":null,"published":"2022-05-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can trigger memory corruption in the HTTP parser by sending crafted requests, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/GHSA-f67m-9j94-qv9j/"}