{"answers":{"affected":"2 open source packages ship an affected version, including opencv.","exploited":"There is no known exploitation of GHSA-f698-m2v9-5fh3 in the wild and no public exploit code.","fix":"Upgrade opencv to 6.1.0 or later.","what":"GHSA-f698-m2v9-5fh3 is a command injection vulnerability in opencv, published on 4 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-f698-m2v9-5fh3 and fix it if it is affected.\n\nWhat it is: GHSA-f698-m2v9-5fh3 is a command injection vulnerability in opencv, published on 4 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-f698-m2v9-5fh3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- opencv (npm): affected all versions; fixed in 6.1.0\n- opencv (npm): affected all versions; fixed in 6.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-f698-m2v9-5fh3/ (Markdown: https://insights.sbomify.com/GHSA-f698-m2v9-5fh3/index.md)","id":"GHSA-f698-m2v9-5fh3","markdown":"https://insights.sbomify.com/GHSA-f698-m2v9-5fh3/index.md","name":"GHSA-f698-m2v9-5fh3","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCV npm package","requires_auth":"none","summary":"Attackers can execute arbitrary commands via unvalidated input in the find-opencv.js utility script of the OpenCV npm package.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `opencv`prior to 6.1.0 are vulnerable to Command Injection. The utils/ script find-opencv.js does not validate user input allowing attackers to execute arbitrary commands.\n\n## Recommendation\n\nUpgrade to version 6.1.0.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Command Injection in opencv","id":"GHSA-f698-m2v9-5fh3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["6.1.0"],"introduced":["0"],"last_affected":[],"package":"opencv","purl":null,"source":"GHSA-f698-m2v9-5fh3"},{"ecosystem":"npm","fixed":["6.1.0"],"introduced":["0"],"last_affected":[],"package":"opencv","purl":"pkg:npm/opencv","source":"GHSA-f698-m2v9-5fh3"}],"products":null,"published":"2019-06-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary commands via unvalidated input in the find-opencv.js utility script of the OpenCV npm package.","url":"https://insights.sbomify.com/GHSA-f698-m2v9-5fh3/"}