{"answers":{"affected":"2 open source packages ship an affected version, including openclaw.","exploited":"There is no known exploitation of GHSA-f6h3-846h-2r8w in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.2.22 or later.","what":"GHSA-f6h3-846h-2r8w is a missing authorization vulnerability in openclaw, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-f6h3-846h-2r8w and fix it if it is affected.\n\nWhat it is: GHSA-f6h3-846h-2r8w is a missing authorization vulnerability in openclaw, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-f6h3-846h-2r8w in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected all versions; fixed in 2026.2.22\n- openclaw (npm): affected all versions; fixed in 2026.2.22\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-f6h3-846h-2r8w/ (Markdown: https://insights.sbomify.com/GHSA-f6h3-846h-2r8w/index.md)","id":"GHSA-f6h3-846h-2r8w","markdown":"https://insights.sbomify.com/GHSA-f6h3-846h-2r8w/index.md","name":"GHSA-f6h3-846h-2r8w","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenClaw npm library","requires_auth":"low_privilege","summary":"Attackers can bypass elevated sender authorization checks in OpenClaw by exploiting broader identity signal matching in specific configurations.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\nIn certain elevated-mode configurations, `tools.elevated.allowFrom` accepted broader identity signals than intended. The fix tightens matching to sender-scoped identity by default and makes mutable metadata matching explicit.\n\n### Context\nOpenClaw is commonly used in 1:1 chats or trusted group chats. In that intended model, this issue is best treated as authorization hardening / defense-in-depth for elevated sender approval.\n\n### Affected Packages / Versions\n- Package: `openclaw` (npm)\n- Latest published npm version at triage: `2026.2.21-2`\n- Affected versions: `\u003c= 2026.2.21-2`\n- Planned patched version (pre-set for publish-ready advisory): `2026.2.22`\n\n### Details\nElevated sender authorization now matches sender-scoped identity values only by default (`SenderId`, `From`, `SenderE164`) and no longer considers recipient routing fields such as `ctx.To`.\n\nMutable sender metadata (`SenderName`, `SenderUsername`, `SenderTag`) now requires explicit allowlist prefixes (`name:`, `username:`, `tag:`). Explicit identity prefixes are also supported (`id:`, `from:`, `e164:`).\n\n### Fix Commit(s)\n- `6817c0ec7b4fa830123d4f5c340f075a4bd04ee2`\n\n### Release Process Note\nThe advisory `patched_versions` is pre-set to the planned next release (`2026.2.22`). Once npm `openclaw@2026.2.22` is published, this advisory can be published without additional content edits.\n\nOpenClaw thanks @jiseoung for reporting.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenClaw's elevated allowFrom accepted broader identity signals than specified within sender-scoped authorization","id":"GHSA-f6h3-846h-2r8w","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2026.2.22"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-f6h3-846h-2r8w"},{"ecosystem":"npm","fixed":["2026.2.22"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-f6h3-846h-2r8w"}],"products":null,"published":"2026-03-04","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass elevated sender authorization checks in OpenClaw by exploiting broader identity signal matching in specific configurations.","url":"https://insights.sbomify.com/GHSA-f6h3-846h-2r8w/"}