GHSA-f77q-r5qm-w4m8 sp1-recursion-gnark-ffi has insufficient range checks of BabyBear arithmetic

Not scored Published
Exploited in the wild
Not known
Fix
Available

What is GHSA-f77q-r5qm-w4m8?

GHSA-f77q-r5qm-w4m8 is a vulnerability in sp1-recursion-gnark-ffi, published on 29 Oct 2024.

Official description

The Gnark recursion circuit constrains arithmetic over BabyBear when the native field of the ZKP circuit is the BN254 scalar field. Proper implementation of this logic requires range checking Bn254 values to be less than the BabyBear modulus.

In versions < 1.2.0, functions like InvF and InvE used values generated by hints that were not appropriately range checked. These issues are resolved in versions 1.2.0 and higher, by adding range checks in the appropriate places. This code was covered under the original audit scope of the recursion circuit audit by Veridise, and both Veridise and Kalos revisited the code for similar issues and found no additional vulnerabilities.

This issue was discovered by the Succinct team on September 3rd. The issue was fixed and resolved within 48 hours, and released with V1.2.0 (note that a later V2.0.0 release has the same contents as V1.2.0 to respect semver), with production SP1 users being notified and upgraded immediately. The V1.1.0 verifier was frozen on September 4th to ensure that no one uses versions of SP1 with this bug.

Which versions are affected by GHSA-f77q-r5qm-w4m8?

2 open source packages ship an affected version, including sp1-recursion-gnark-ffi.

PackageAffectedFixed in
sp1-recursion-gnark-ffi crates.ioAll versions1.2.0
sp1-recursion-gnark-ffi crates.ioAll versions1.2.0

How do I fix GHSA-f77q-r5qm-w4m8?

Upgrade sp1-recursion-gnark-ffi to 1.2.0 or later.

Is GHSA-f77q-r5qm-w4m8 being exploited?

There is no known exploitation of GHSA-f77q-r5qm-w4m8 in the wild and no public exploit code.

Sources

Is GHSA-f77q-r5qm-w4m8 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free