# GHSA-f7cq-5v43-8pwp: Traefik vulnerable to GO issue allowing malformed DNS message to cause infinite loop

> Traefik is vulnerable to a denial of service attack via malformed DNS messages, requiring an upgrade to patched versions.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 May 2024
- **Also known as:** GO-2024-2880

## What is GHSA-f7cq-5v43-8pwp?

GHSA-f7cq-5v43-8pwp is a denial of service vulnerability in github.com/traefik/traefik, published on 23 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact

There is a vulnerability in [GO managing malformed DNS message](https://groups.google.com/g/golang-announce/c/wkkO4P9stm0), which impacts Traefik.
This vulnerability could be exploited to cause a denial of service.

### References

- [CVE-2024-24788](https://www.cve.org/CVERecord?id=CVE-2024-24788)

### Patches

- https://github.com/traefik/traefik/releases/tag/v2.11.3
- https://github.com/traefik/traefik/releases/tag/v3.0.1

### Workarounds

No workaround.

### For more information

If you have any questions or comments about this advisory, please [open an issue](https://github.com/traefik/traefik/issues).

## Which versions are affected by GHSA-f7cq-5v43-8pwp?

9 open source packages ship an affected version, including github.com/traefik/traefik, github.com/traefik/traefik/v2 and github.com/traefik/traefik/v3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/traefik/traefik` | Go | All versions | None |
| `github.com/traefik/traefik` | Go | All versions to 1.7.34 | None |
| `github.com/traefik/traefik` | Go | All versions to 1.7.34 | None |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.11.3 |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.11.3 |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.11.3 |
| `github.com/traefik/traefik/v3` | Go | All versions | 3.0.1 |
| `github.com/traefik/traefik/v3` | Go | All versions | 3.0.1 |
| `github.com/traefik/traefik/v3` | Go | All versions | 3.0.1 |

## How do I fix GHSA-f7cq-5v43-8pwp?

Upgrade to a fixed version.

## Is GHSA-f7cq-5v43-8pwp being exploited?

There is no known exploitation of GHSA-f7cq-5v43-8pwp in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-f7cq-5v43-8pwp and fix it if it is affected.

What it is: GHSA-f7cq-5v43-8pwp is a denial of service vulnerability in github.com/traefik/traefik, published on 23 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-f7cq-5v43-8pwp in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/traefik/traefik (Go): affected all versions; no fix listed
- github.com/traefik/traefik (Go): affected all versions up to 1.7.34; no fix listed
- github.com/traefik/traefik (Go): affected all versions up to 1.7.34; no fix listed
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.3
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.3
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.11.3
- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.0.1
- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.0.1
- github.com/traefik/traefik/v3 (Go): affected all versions; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-f7cq-5v43-8pwp/ (Markdown: https://insights.sbomify.com/GHSA-f7cq-5v43-8pwp/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-f7cq-5v43-8pwp

---
From sbomify Insights: https://insights.sbomify.com/GHSA-f7cq-5v43-8pwp/
Summaries are generated and may contain mistakes; the official description above is the record.
