GHSA-f7qw-5fgj-247x Cross-site Scripting and Open Redirect in plone.app.contenttypes
Cache poisoning allows attackers to inject scripts or redirect users via the image_view_fullscreen page in Plone.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is GHSA-f7qw-5fgj-247x?
GHSA-f7qw-5fgj-247x is a cross-site scripting vulnerability in plone-app-contenttypes, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Impact
Plone is vulnerable to reflected cross site scripting and open redirect when an attacker can get a compromised version of the image_view_fullscreen page in a cache, for example in Varnish. The technique is known as cache poisoning. Any later visitor can get redirected when clicking on a link on this page. Usually only anonymous users are affected, but this depends on your cache settings.
Patches
New versions of plone.app.contenttypes have been released. Version 2.2.3 works on Plone 5.2 and will be included in Plone 5.2.7. Version 3.0.0a9 works on Plone 6 and will be included in Plone 6.0.0a3.
Note that the Products.CMFPlone package has the same problem in the 4.3 series. In Plone 5.0-5.2, the default Products.ATContentTypes version has the same problem. See advisory. For all unpatched versions of the three packages, you can use the following workaround.
Workaround
Make sure the image_view_fullscreen page is not stored in the cache. In Plone:
- Login as Manager and go to Site Setup.
- Go to the 'Caching' control panel. If this does not exist, or 'Enable caching' is not checked, you should normally not be vulnerable.
- Click on the tab 'Caching operations'.
- Under 'Legacy template mappings' locate the ruleset 'Content item view'.
- From the last column ('Templates') remove 'image_view_fullscreen'.
- Click on Save.
Reporter
This vulnerability was responsibly disclosed to the Plone Security Team by Gustav Hansen, F-Secure Consulting. Thank you!
For more information
If you have any questions or comments about this advisory, email us at [email protected] This is also the correct address to use when you want to report a possible vulnerability. See our security report policy.
Which versions are affected by GHSA-f7qw-5fgj-247x?
2 open source packages ship an affected version, including plone-app-contenttypes and plone.app.contenttypes.
| Package | Affected | Fixed in |
|---|---|---|
plone-app-contenttypes PyPI | All versions | 2.2.3 |
plone.app.contenttypes PyPI | All versions | 2.2.3 |
How do I fix GHSA-f7qw-5fgj-247x?
Upgrade plone-app-contenttypes to 2.2.3 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is GHSA-f7qw-5fgj-247x being exploited?
There is no known exploitation of GHSA-f7qw-5fgj-247x in the wild and no public exploit code.