# GHSA-f7qw-5fgj-247x: Cross-site Scripting and Open Redirect in plone.app.contenttypes

> Cache poisoning allows attackers to inject scripts or redirect users via the image_view_fullscreen page in Plone.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Feb 2022

## What is GHSA-f7qw-5fgj-247x?

GHSA-f7qw-5fgj-247x is a cross-site scripting vulnerability in plone-app-contenttypes, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

### Impact
Plone is vulnerable to reflected cross site scripting and open redirect when an attacker can get a compromised version of the image_view_fullscreen page in a cache, for example in Varnish.
The technique is known as cache poisoning.
Any later visitor can get redirected when clicking on a link on this page.
Usually only anonymous users are affected, but this depends on your cache settings.

### Patches
New versions of plone.app.contenttypes have been released.
Version 2.2.3 works on Plone 5.2 and will be included in Plone 5.2.7.
Version 3.0.0a9 works on Plone 6 and will be included in Plone 6.0.0a3.

Note that the Products.CMFPlone package has the same problem in the 4.3 series.
In Plone 5.0-5.2, the default Products.ATContentTypes version has the same problem. See [advisory](https://github.com/plone/Products.ATContentTypes/security/advisories/GHSA-g4c2-ghfg-g5rh).
For all unpatched versions of the three packages, you can use the following workaround.

### Workaround
Make sure the image_view_fullscreen page is not stored in the cache.
In Plone:

* Login as Manager and go to Site Setup.
* Go to the 'Caching' control panel. If this does not exist, or 'Enable caching' is not checked, you should normally not be vulnerable.
* Click on the tab 'Caching operations'.
* Under 'Legacy template mappings' locate the ruleset 'Content item view'.
* From the last column ('Templates')  remove 'image_view_fullscreen'.
* Click on Save.

### Reporter
This vulnerability was responsibly disclosed to the Plone Security Team by Gustav Hansen, F-Secure Consulting. Thank you!

### For more information
If you have any questions or comments about this advisory, email us at [security@plone.org](mailto:security@plone.org)
This is also the correct address to use when you want to report a possible vulnerability.
See [our security report policy](https://plone.org/security/report).

## Which versions are affected by GHSA-f7qw-5fgj-247x?

2 open source packages ship an affected version, including plone-app-contenttypes and plone.app.contenttypes.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone-app-contenttypes` | PyPI | All versions | 2.2.3 |
| `plone.app.contenttypes` | PyPI | All versions | 2.2.3 |

## How do I fix GHSA-f7qw-5fgj-247x?

Upgrade plone-app-contenttypes to 2.2.3 or later.

## Is GHSA-f7qw-5fgj-247x being exploited?

There is no known exploitation of GHSA-f7qw-5fgj-247x in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-f7qw-5fgj-247x and fix it if it is affected.

What it is: GHSA-f7qw-5fgj-247x is a cross-site scripting vulnerability in plone-app-contenttypes, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-f7qw-5fgj-247x in the wild and no public exploit code.

Affected packages and fixed versions:
- plone-app-contenttypes (PyPI): affected all versions; fixed in 2.2.3
- plone.app.contenttypes (PyPI): affected all versions; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-f7qw-5fgj-247x/ (Markdown: https://insights.sbomify.com/GHSA-f7qw-5fgj-247x/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-f7qw-5fgj-247x

---
From sbomify Insights: https://insights.sbomify.com/GHSA-f7qw-5fgj-247x/
Summaries are generated and may contain mistakes; the official description above is the record.
