{"answers":{"affected":"2 open source packages ship an affected version, including ircdkit.","exploited":"There is no known exploitation of GHSA-f7r3-p866-q9qr in the wild and no public exploit code.","fix":"Upgrade ircdkit to 1.0.4 or later.","what":"GHSA-f7r3-p866-q9qr is a denial of service vulnerability in ircdkit, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-f7r3-p866-q9qr and fix it if it is affected.\n\nWhat it is: GHSA-f7r3-p866-q9qr is a denial of service vulnerability in ircdkit, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-f7r3-p866-q9qr in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ircdkit (npm): affected all versions; fixed in 1.0.4\n- ircdkit (npm): affected all versions; fixed in 1.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-f7r3-p866-q9qr/ (Markdown: https://insights.sbomify.com/GHSA-f7r3-p866-q9qr/index.md)","id":"GHSA-f7r3-p866-q9qr","markdown":"https://insights.sbomify.com/GHSA-f7r3-p866-q9qr/index.md","name":"GHSA-f7r3-p866-q9qr","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"IRC library","requires_auth":"none","summary":"Remote attackers can cause a denial of service in applications using the ircdkit library by triggering an unhandled connection end event.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `ircdkit` 1.0.3 and prior are vulnerable to a remote denial of service.\n\n## Recommendation\n\nUpgrade to version 1.0.4.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ircdkit vulnerable to Denial of Service due to unhandled connection end event","id":"GHSA-f7r3-p866-q9qr","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.0.4"],"introduced":["0"],"last_affected":[],"package":"ircdkit","purl":null,"source":"GHSA-f7r3-p866-q9qr"},{"ecosystem":"npm","fixed":["1.0.4"],"introduced":["0"],"last_affected":[],"package":"ircdkit","purl":"pkg:npm/ircdkit","source":"GHSA-f7r3-p866-q9qr"}],"products":null,"published":"2019-06-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Remote attackers can cause a denial of service in applications using the ircdkit library by triggering an unhandled connection end event.","url":"https://insights.sbomify.com/GHSA-f7r3-p866-q9qr/"}