# GHSA-f897-62hf-6gxq: MCP TypeScript SDK: HTTP server transports and handlers did not limit request body size or JSON-RPC batch length


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Oct 2026

## What is GHSA-f897-62hf-6gxq?

GHSA-f897-62hf-6gxq is a vulnerability in @modelcontextprotocol/hono, published on 27 Oct 2026. 

### Official description

### Summary
In affected versions, MCP servers reachable over HTTP put no limit on the size of a POST body or on the number of messages in a JSON-RPC batch. Large requests could exhaust the server's memory, and one long batch could block it from serving anyone else. No credentials were needed, unless your application authenticates requests before they reach the SDK.

### Am I affected?
Yes, if clients you do not fully trust can reach your server over Streamable HTTP. A body parser such as `express.json()` does not protect you, because it does not limit batch length. Servers that only use stdio are not affected.

Affected versions:

- `@modelcontextprotocol/sdk` 1.10.0 through 1.30.0
- `@modelcontextprotocol/server` 2.0.0
- `@modelcontextprotocol/node` 2.0.0
- `@modelcontextprotocol/hono` 2.0.0

### Fix
Upgrade to:

- 1.x: `@modelcontextprotocol/sdk` 1.30.1 or later
- 2.x: `@modelcontextprotocol/server` 2.1.0, `@modelcontextprotocol/node` 2.1.0 and `@modelcontextprotocol/hono` 2.0.1 or later. Upgrade every one you have installed.

Bodies over 4 MiB now get `413`, and batches over 100 messages get `400`. If your clients send larger bodies, raise the new `maxRequestBodySize` option.

If you cannot upgrade yet, cap request body size in a reverse proxy.

## Which versions are affected by GHSA-f897-62hf-6gxq?

8 open source packages ship an affected version, including @modelcontextprotocol/hono, @modelcontextprotocol/node and @modelcontextprotocol/sdk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@modelcontextprotocol/hono` | npm | From 2.0.0 | 2.0.1 |
| `@modelcontextprotocol/hono` | npm | From 2.0.0 | 2.0.1 |
| `@modelcontextprotocol/node` | npm | From 2.0.0 | 2.1.0 |
| `@modelcontextprotocol/node` | npm | From 2.0.0 | 2.1.0 |
| `@modelcontextprotocol/sdk` | npm | From 1.10.0 | 1.30.1 |
| `@modelcontextprotocol/sdk` | npm | From 1.10.0 | 1.30.1 |
| `@modelcontextprotocol/server` | npm | From 2.0.0 | 2.1.0 |
| `@modelcontextprotocol/server` | npm | From 2.0.0 | 2.1.0 |

## How do I fix GHSA-f897-62hf-6gxq?

Upgrade @modelcontextprotocol/hono to 2.0.1 or later.

## Is GHSA-f897-62hf-6gxq being exploited?

There is no known exploitation of GHSA-f897-62hf-6gxq in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-f897-62hf-6gxq and fix it if it is affected.

What it is: GHSA-f897-62hf-6gxq is a vulnerability in @modelcontextprotocol/hono, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of GHSA-f897-62hf-6gxq in the wild and no public exploit code.

Affected packages and fixed versions:
- @modelcontextprotocol/hono (npm): affected from 2.0.0; fixed in 2.0.1
- @modelcontextprotocol/hono (npm): affected from 2.0.0; fixed in 2.0.1
- @modelcontextprotocol/node (npm): affected from 2.0.0; fixed in 2.1.0
- @modelcontextprotocol/node (npm): affected from 2.0.0; fixed in 2.1.0
- @modelcontextprotocol/sdk (npm): affected from 1.10.0; fixed in 1.30.1
- @modelcontextprotocol/sdk (npm): affected from 1.10.0; fixed in 1.30.1
- @modelcontextprotocol/server (npm): affected from 2.0.0; fixed in 2.1.0
- @modelcontextprotocol/server (npm): affected from 2.0.0; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-f897-62hf-6gxq/ (Markdown: https://insights.sbomify.com/GHSA-f897-62hf-6gxq/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-f897-62hf-6gxq

---
From sbomify Insights: https://insights.sbomify.com/GHSA-f897-62hf-6gxq/
Summaries are generated and may contain mistakes; the official description above is the record.
