{"answers":{"affected":"2 open source packages ship an affected version, including htmr.","exploited":"There is no known exploitation of GHSA-f8rq-m28h-8hxj in the wild and no public exploit code.","fix":"Upgrade htmr to 0.8.7 or later.","what":"GHSA-f8rq-m28h-8hxj is a cross-site scripting vulnerability in htmr, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-f8rq-m28h-8hxj and fix it if it is affected.\n\nWhat it is: GHSA-f8rq-m28h-8hxj is a cross-site scripting vulnerability in htmr, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-f8rq-m28h-8hxj in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- htmr (npm): affected all versions; fixed in 0.8.7\n- htmr (npm): affected all versions; fixed in 0.8.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-f8rq-m28h-8hxj/ (Markdown: https://insights.sbomify.com/GHSA-f8rq-m28h-8hxj/index.md)","id":"GHSA-f8rq-m28h-8hxj","markdown":"https://insights.sbomify.com/GHSA-f8rq-m28h-8hxj/index.md","name":"GHSA-f8rq-m28h-8hxj","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript HTML renderer","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript in a victim's browser via DOM-based XSS in the htmr library, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `htmr` prior to 0.8.7 are vulnerable to Cross-Site Scripting (XSS).  The package uses `innerHTML` to unescape HTML entities. This may lead to [DOM-based XSS](https://owasp.org/www-community/attacks/DOM_Based_XSS) through HTML-encoded XSS payloads. This may allow an attacker to execute arbitrary JavaScript in a victim's browser.\n\n## Recommendation\n\nUpgrade to version 0.8.7 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in htmr","id":"GHSA-f8rq-m28h-8hxj","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.8.7"],"introduced":["0"],"last_affected":[],"package":"htmr","purl":null,"source":"GHSA-f8rq-m28h-8hxj"},{"ecosystem":"npm","fixed":["0.8.7"],"introduced":["0"],"last_affected":[],"package":"htmr","purl":"pkg:npm/htmr","source":"GHSA-f8rq-m28h-8hxj"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can execute arbitrary JavaScript in a victim's browser via DOM-based XSS in the htmr library, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/GHSA-f8rq-m28h-8hxj/"}