{"answers":{"affected":"2 open source packages ship an affected version, including webp.","exploited":"There is no known exploitation of GHSA-f9pm-4g9p-6vm3 in the wild and no public exploit code.","fix":"Upgrade webp to 0.3.0 or later.","what":"GHSA-f9pm-4g9p-6vm3 is a memory corruption vulnerability in webp, published on 6 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-f9pm-4g9p-6vm3 and fix it if it is affected.\n\nWhat it is: GHSA-f9pm-4g9p-6vm3 is a memory corruption vulnerability in webp, published on 6 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-f9pm-4g9p-6vm3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- webp (PyPI): affected all versions; fixed in 0.3.0\n- webp (PyPI): affected all versions; fixed in 0.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-f9pm-4g9p-6vm3/ (Markdown: https://insights.sbomify.com/GHSA-f9pm-4g9p-6vm3/index.md)","id":"GHSA-f9pm-4g9p-6vm3","markdown":"https://insights.sbomify.com/GHSA-f9pm-4g9p-6vm3/index.md","name":"GHSA-f9pm-4g9p-6vm3","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python image library","requires_auth":"none","summary":"A heap buffer overflow in the bundled libwebp allows remote attackers to execute arbitrary code via malicious WebP images.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\npywebp versions before v0.3.0 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. The vulnerability was a heap buffer overflow which allowed a remote attacker to perform an out of bounds memory write.\n\n### Patches\nThe problem has been patched upstream in libwebp 1.3.2.\npywebp was updated to bundle a patched version of libwebp in v0.3.0.\n\n### Workarounds\nNo known workarounds without upgrading.\n\n### References\n- https://www.rezilion.com/blog/rezilion-researchers-uncover-new-details-on-severity-of-google-chrome-zero-day-vulnerability-cve-2023-4863/\n- https://nvd.nist.gov/vuln/detail/CVE-2023-4863","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Bundled libwebp in pywebp vulnerable","id":"GHSA-f9pm-4g9p-6vm3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["0.3.0"],"introduced":["0"],"last_affected":[],"package":"webp","purl":null,"source":"GHSA-f9pm-4g9p-6vm3"},{"ecosystem":"PyPI","fixed":["0.3.0"],"introduced":["0"],"last_affected":[],"package":"webp","purl":"pkg:pypi/webp","source":"GHSA-f9pm-4g9p-6vm3"}],"products":null,"published":"2023-10-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A heap buffer overflow in the bundled libwebp allows remote attackers to execute arbitrary code via malicious WebP images.","url":"https://insights.sbomify.com/GHSA-f9pm-4g9p-6vm3/"}