{"answers":{"affected":"2 open source packages ship an affected version, including DotNetNuke.Core.","exploited":"There is no known exploitation of GHSA-fcpv-w245-r2q7 in the wild and no public exploit code.","fix":"Upgrade DotNetNuke.Core to 10.2.2 or later.","what":"GHSA-fcpv-w245-r2q7 is a vulnerability in DotNetNuke.Core, published on 14 Apr 2026."},"fix_prompt":"Check this codebase for GHSA-fcpv-w245-r2q7 and fix it if it is affected.\n\nWhat it is: GHSA-fcpv-w245-r2q7 is a vulnerability in DotNetNuke.Core, published on 14 Apr 2026. \nExploitation: There is no known exploitation of GHSA-fcpv-w245-r2q7 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- DotNetNuke.Core (NuGet): affected from 6.0.0; fixed in 10.2.2\n- DotNetNuke.Core (NuGet): affected from 6.0.0; fixed in 10.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-fcpv-w245-r2q7/ (Markdown: https://insights.sbomify.com/GHSA-fcpv-w245-r2q7/index.md)","id":"GHSA-fcpv-w245-r2q7","markdown":"https://insights.sbomify.com/GHSA-fcpv-w245-r2q7/index.md","name":"GHSA-fcpv-w245-r2q7","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"unknown","non_default_config":false,"product_category":"DotNetNuke Core Library","requires_auth":"unknown","summary":"Static analysis warnings indicate potential weak cryptography and XML processing issues in the DotNetNuke Core library.","user_interaction":"unknown","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The codebase raises code analysis warnings related to security, including CA3075, CA5366, CA5371, CA5368, CA5369, CA5372, CA5379, CA5350, and CA5351.\n\nMost of these deal with disabling DTD processing in XML documents, but also includes cryptographic algorithm choices.","ecosystems":["NuGet"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"DotNetNuke.Core security code analysis rules triggered","id":"GHSA-fcpv-w245-r2q7","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"NuGet","fixed":["10.2.2"],"introduced":["6.0.0"],"last_affected":[],"package":"DotNetNuke.Core","purl":null,"source":"GHSA-fcpv-w245-r2q7"},{"ecosystem":"NuGet","fixed":["10.2.2"],"introduced":["6.0.0"],"last_affected":[],"package":"DotNetNuke.Core","purl":"pkg:nuget/DotNetNuke.Core","source":"GHSA-fcpv-w245-r2q7"}],"products":null,"published":"2026-04-14","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Static analysis warnings indicate potential weak cryptography and XML processing issues in the DotNetNuke Core library.","url":"https://insights.sbomify.com/GHSA-fcpv-w245-r2q7/"}