{"answers":{"affected":"2 open source packages ship an affected version, including fuel/core.","exploited":"There is no known exploitation of GHSA-fgrx-4637-fcf5 in the wild and no public exploit code.","fix":"Upgrade fuel/core to 1.8.1 or later.","what":"GHSA-fgrx-4637-fcf5 is a vulnerability in fuel/core, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-fgrx-4637-fcf5 and fix it if it is affected.\n\nWhat it is: GHSA-fgrx-4637-fcf5 is a vulnerability in fuel/core, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-fgrx-4637-fcf5 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fuel/core (Packagist): affected all versions; fixed in 1.8.1\n- fuel/core (Packagist): affected all versions; fixed in 1.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-fgrx-4637-fcf5/ (Markdown: https://insights.sbomify.com/GHSA-fgrx-4637-fcf5/index.md)","id":"GHSA-fgrx-4637-fcf5","markdown":"https://insights.sbomify.com/GHSA-fgrx-4637-fcf5/index.md","name":"GHSA-fgrx-4637-fcf5","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"FuelPHP core library","requires_auth":"none","summary":"Weak encryption in FuelPHP core allows attackers to decrypt sensitive data using GPU power, compromising confidentiality.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"In fuel/core versions pior to 1.8.1, with the right knowledge, code, and GPU calculation power, Crypt encryption can be broken in minutes.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"fuel/core Crypt encryption compromised.","id":"GHSA-fgrx-4637-fcf5","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"fuel/core","purl":null,"source":"GHSA-fgrx-4637-fcf5"},{"ecosystem":"Packagist","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"fuel/core","purl":"pkg:composer/fuel/core","source":"GHSA-fgrx-4637-fcf5"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Weak encryption in FuelPHP core allows attackers to decrypt sensitive data using GPU power, compromising confidentiality.","url":"https://insights.sbomify.com/GHSA-fgrx-4637-fcf5/"}