{"answers":{"affected":"2 open source packages ship an affected version, including ibexa/http-cache.","exploited":"There is no known exploitation of GHSA-fh7v-q458-7vmw in the wild and no public exploit code.","fix":"Upgrade ibexa/http-cache to 4.6.14 or later.","what":"GHSA-fh7v-q458-7vmw is a vulnerability in ibexa/http-cache, published on 2 Dec 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-fh7v-q458-7vmw and fix it if it is affected.\n\nWhat it is: GHSA-fh7v-q458-7vmw is a vulnerability in ibexa/http-cache, published on 2 Dec 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-fh7v-q458-7vmw in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ibexa/http-cache (Packagist): affected from 4.6.0; fixed in 4.6.14\n- ibexa/http-cache (Packagist): affected from 4.6.0; fixed in 4.6.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-fh7v-q458-7vmw/ (Markdown: https://insights.sbomify.com/GHSA-fh7v-q458-7vmw/index.md)","id":"GHSA-fh7v-q458-7vmw","markdown":"https://insights.sbomify.com/GHSA-fh7v-q458-7vmw/index.md","name":"GHSA-fh7v-q458-7vmw","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"configuration_change","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Varnish VCL templates","requires_auth":"low_privilege","summary":"Attackers can extract secrets from HTTP responses via BREACH attack due to enabled compression in Varnish VCL templates.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThis is not a vulnerability in the code per se, but included Varnish VCL templates enable compression of API and JSON messages. This is a potential case of the BREACH vulnerability, which affects HTTP compression, where secrets can be extracted through carefully crafted requests. The fix disables compression in these templates. Please make sure to make the same change in your configuration files, see the release notes for specific instructions. Please check your web server configuration as well.\n\n### Patches\n- See \"Patched versions\".\n- https://github.com/ibexa/http-cache/commit/e03f683e8db53b6d253e1af8177befeecc8d3914\n\n### Workarounds\nMake sure HTTP compression is disabled for REST API requests and other communication that might contain secrets.\n\n### References\n- Advisory: https://developers.ibexa.co/security-advisories/ibexa-sa-2024-006-vulnerabilities-in-content-name-pattern-commerce-shop-and-varnish-vhost-templates\n- Release notes: https://doc.ibexa.co/en/latest/update_and_migration/from_4.6/update_from_4.6/#v4614\n- https://github.com/ibexa/post-install/security/advisories/GHSA-4h8f-c635-25p7\n- https://github.com/ezsystems/ezplatform-http-cache/security/advisories/GHSA-mgfg-7533-7jf6\n- https://www.breachattack.com/","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ibexa/http-cache affected by Breach with Varnish VCL","id":"GHSA-fh7v-q458-7vmw","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["4.6.14"],"introduced":["4.6.0"],"last_affected":[],"package":"ibexa/http-cache","purl":null,"source":"GHSA-fh7v-q458-7vmw"},{"ecosystem":"Packagist","fixed":["4.6.14"],"introduced":["4.6.0"],"last_affected":[],"package":"ibexa/http-cache","purl":"pkg:composer/ibexa/http-cache","source":"GHSA-fh7v-q458-7vmw"}],"products":null,"published":"2024-12-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can extract secrets from HTTP responses via BREACH attack due to enabled compression in Varnish VCL templates.","url":"https://insights.sbomify.com/GHSA-fh7v-q458-7vmw/"}