{"answers":{"affected":"2 open source packages ship an affected version, including io.github.skylot:jadx-core.","exploited":"There is no known exploitation of GHSA-fjh6-p566-wr6q in the wild and no public exploit code.","fix":"Upgrade io.github.skylot:jadx-core to 1.4.3 or later.","what":"GHSA-fjh6-p566-wr6q is a vulnerability in io.github.skylot:jadx-core, published on 21 Jul 2022."},"fix_prompt":"Check this codebase for GHSA-fjh6-p566-wr6q and fix it if it is affected.\n\nWhat it is: GHSA-fjh6-p566-wr6q is a vulnerability in io.github.skylot:jadx-core, published on 21 Jul 2022. \nExploitation: There is no known exploitation of GHSA-fjh6-p566-wr6q in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.github.skylot:jadx-core (Maven): affected all versions; fixed in 1.4.3\n- io.github.skylot:jadx-core (Maven): affected all versions; fixed in 1.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-fjh6-p566-wr6q/ (Markdown: https://insights.sbomify.com/GHSA-fjh6-p566-wr6q/index.md)","id":"GHSA-fjh6-p566-wr6q","markdown":"https://insights.sbomify.com/GHSA-fjh6-p566-wr6q/index.md","name":"GHSA-fjh6-p566-wr6q","record":{"aliases":[],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["other"],"network_reachable":"unknown","non_default_config":false,"product_category":"Java decompiler","requires_auth":"unknown","summary":"Jadx is affected by a vulnerability in its bundled protobuf-java dependency, requiring an upgrade to the latest version.","user_interaction":"unknown","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nVulnerable library protobuf-java 3.11.4 (CVE-2021-22569)\n\n### Patches\nDependency updated in jadx 1.4.3\n\n### References\nAccording to the AquaSecurity report:\n![05F1C52A666E4FCC844ABD085BD55124](https://user-images.githubusercontent.com/118523/177364939-087e2144-9a8a-4594-ae90-eb2acb0a2036.png)\n\nAlso, Maven repository have links to this and other vulnerabilities from dependencies:\nhttps://mvnrepository.com/artifact/com.google.protobuf/protobuf-java/3.11.4","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"skylot jadx affected by Incorrect Behavior Order in vulnerable dependency","id":"GHSA-fjh6-p566-wr6q","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"other","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["1.4.3"],"introduced":["0"],"last_affected":[],"package":"io.github.skylot:jadx-core","purl":null,"source":"GHSA-fjh6-p566-wr6q"},{"ecosystem":"Maven","fixed":["1.4.3"],"introduced":["0"],"last_affected":[],"package":"io.github.skylot:jadx-core","purl":"pkg:maven/io.github.skylot/jadx-core","source":"GHSA-fjh6-p566-wr6q"}],"products":null,"published":"2022-07-21","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Jadx is affected by a vulnerability in its bundled protobuf-java dependency, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/GHSA-fjh6-p566-wr6q/"}