GHSA-fmg6-246m-9g2v Auth0 laravel-auth0 SDK has Insufficient Entropy in Cookie Encryption
Insufficient entropy in cookie encryption allows attackers to brute-force keys and forge session cookies, leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-fmg6-246m-9g2v?
GHSA-fmg6-246m-9g2v is a vulnerability in auth0/login, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact
In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.
Am I Affected?
You are affected if you meet the following preconditions:
- Applications using laravel-auth0 SDK, versions between 7.0.0 and 7.20.0
- Laravel-auth0 SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.
Resolution
Upgrade Auth0/laravel-auth0 to version 7.21.0 or greater.
Which versions are affected by GHSA-fmg6-246m-9g2v?
2 open source packages ship an affected version, including auth0/login.
| Package | Affected | Fixed in |
|---|---|---|
auth0/login Packagist | From 7.0.0 | 7.21.0 |
auth0/login Packagist | From 7.0.0 | 7.21.0 |
How do I fix GHSA-fmg6-246m-9g2v?
Upgrade auth0/login to 7.21.0 or later.
Is GHSA-fmg6-246m-9g2v being exploited?
There is no known exploitation of GHSA-fmg6-246m-9g2v in the wild and no public exploit code.