{"answers":{"affected":"2 open source packages ship an affected version, including auth0/login.","exploited":"There is no known exploitation of GHSA-fmg6-246m-9g2v in the wild and no public exploit code.","fix":"Upgrade auth0/login to 7.21.0 or later.","what":"GHSA-fmg6-246m-9g2v is a vulnerability in auth0/login, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-fmg6-246m-9g2v and fix it if it is affected.\n\nWhat it is: GHSA-fmg6-246m-9g2v is a vulnerability in auth0/login, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-fmg6-246m-9g2v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/login (Packagist): affected from 7.0.0; fixed in 7.21.0\n- auth0/login (Packagist): affected from 7.0.0; fixed in 7.21.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-fmg6-246m-9g2v/ (Markdown: https://insights.sbomify.com/GHSA-fmg6-246m-9g2v/index.md)","id":"GHSA-fmg6-246m-9g2v","markdown":"https://insights.sbomify.com/GHSA-fmg6-246m-9g2v/index.md","name":"GHSA-fmg6-246m-9g2v","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Auth0 Laravel SDK","requires_auth":"none","summary":"Insufficient entropy in cookie encryption allows attackers to brute-force keys and forge session cookies, leading to account takeover.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nIn applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.\n\n### Am I Affected?\nYou are affected if you meet the following preconditions:\n\n- Applications using laravel-auth0 SDK, versions between 7.0.0 and 7.20.0\n- Laravel-auth0 SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.\n\n### Resolution\nUpgrade Auth0/laravel-auth0 to version 7.21.0 or greater.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Auth0 laravel-auth0 SDK has Insufficient Entropy in Cookie Encryption","id":"GHSA-fmg6-246m-9g2v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["7.21.0"],"introduced":["7.0.0"],"last_affected":[],"package":"auth0/login","purl":null,"source":"GHSA-fmg6-246m-9g2v"},{"ecosystem":"Packagist","fixed":["7.21.0"],"introduced":["7.0.0"],"last_affected":[],"package":"auth0/login","purl":"pkg:composer/auth0/login","source":"GHSA-fmg6-246m-9g2v"}],"products":null,"published":"2026-04-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Insufficient entropy in cookie encryption allows attackers to brute-force keys and forge session cookies, leading to account takeover.","url":"https://insights.sbomify.com/GHSA-fmg6-246m-9g2v/"}