# GHSA-fmg6-246m-9g2v: Auth0 laravel-auth0 SDK has Insufficient Entropy in Cookie Encryption

> Insufficient entropy in cookie encryption allows attackers to brute-force keys and forge session cookies, leading to account takeover.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2026

## What is GHSA-fmg6-246m-9g2v?

GHSA-fmg6-246m-9g2v is a vulnerability in auth0/login, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact
In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.

### Am I Affected?
You are affected if you meet the following preconditions:

- Applications using laravel-auth0 SDK, versions between 7.0.0 and 7.20.0
- Laravel-auth0 SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.

### Resolution
Upgrade Auth0/laravel-auth0 to version 7.21.0 or greater.

## Which versions are affected by GHSA-fmg6-246m-9g2v?

2 open source packages ship an affected version, including auth0/login.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/login` | Packagist | From 7.0.0 | 7.21.0 |
| `auth0/login` | Packagist | From 7.0.0 | 7.21.0 |

## How do I fix GHSA-fmg6-246m-9g2v?

Upgrade auth0/login to 7.21.0 or later.

## Is GHSA-fmg6-246m-9g2v being exploited?

There is no known exploitation of GHSA-fmg6-246m-9g2v in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-fmg6-246m-9g2v and fix it if it is affected.

What it is: GHSA-fmg6-246m-9g2v is a vulnerability in auth0/login, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-fmg6-246m-9g2v in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/login (Packagist): affected from 7.0.0; fixed in 7.21.0
- auth0/login (Packagist): affected from 7.0.0; fixed in 7.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-fmg6-246m-9g2v/ (Markdown: https://insights.sbomify.com/GHSA-fmg6-246m-9g2v/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-fmg6-246m-9g2v

---
From sbomify Insights: https://insights.sbomify.com/GHSA-fmg6-246m-9g2v/
Summaries are generated and may contain mistakes; the official description above is the record.
