{"answers":{"affected":"2 open source packages ship an affected version, including @vitejs/plugin-rsc.","exploited":"There is no known exploitation of GHSA-fmh4-wr37-44fp in the wild and no public exploit code.","fix":"Upgrade @vitejs/plugin-rsc to 0.5.3 or later.","what":"GHSA-fmh4-wr37-44fp is an unsafe deserialization vulnerability in @vitejs/plugin-rsc, published on 3 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-fmh4-wr37-44fp and fix it if it is affected.\n\nWhat it is: GHSA-fmh4-wr37-44fp is an unsafe deserialization vulnerability in @vitejs/plugin-rsc, published on 3 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-fmh4-wr37-44fp in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @vitejs/plugin-rsc (npm): affected all versions; fixed in 0.5.3\n- @vitejs/plugin-rsc (npm): affected all versions; fixed in 0.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-fmh4-wr37-44fp/ (Markdown: https://insights.sbomify.com/GHSA-fmh4-wr37-44fp/index.md)","id":"GHSA-fmh4-wr37-44fp","markdown":"https://insights.sbomify.com/GHSA-fmh4-wr37-44fp/index.md","name":"GHSA-fmh4-wr37-44fp","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"React Server Components plugin","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary code via deserialization in React Server Components plugins, requiring immediate upgrades.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\n\n`@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained an unauthenticated remote code execution vulnerability in versions prior to 19.0.1, 19.1.2, and 19.2.1. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-fv66-9v8q-g76r\n\n### Impact\n\nApplications using affected versions of `@vitejs/plugin-rsc` are vulnerable to unauthenticated remote code execution through deserialization of untrusted data. An attacker can execute arbitrary code remotely without authentication, affecting confidentiality, integrity, and availability.\n\n### Recommendations\n\nUpgrade immediately to `@vitejs/plugin-rsc@0.5.3` or later.\n\n### Workarounds\n\nApplications not using server-side React or React Server Components are unaffected.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"React Server Components are Vulnerable to RCE","id":"GHSA-fmh4-wr37-44fp","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.5.3"],"introduced":["0"],"last_affected":[],"package":"@vitejs/plugin-rsc","purl":null,"source":"GHSA-fmh4-wr37-44fp"},{"ecosystem":"npm","fixed":["0.5.3"],"introduced":["0"],"last_affected":[],"package":"@vitejs/plugin-rsc","purl":"pkg:npm/%40vitejs/plugin-rsc","source":"GHSA-fmh4-wr37-44fp"}],"products":null,"published":"2025-12-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Unauthenticated attackers can execute arbitrary code via deserialization in React Server Components plugins, requiring immediate upgrades.","url":"https://insights.sbomify.com/GHSA-fmh4-wr37-44fp/"}