# GHSA-fmh4-wr37-44fp: React Server Components are Vulnerable to RCE

> Unauthenticated attackers can execute arbitrary code via deserialization in React Server Components plugins, requiring immediate upgrades.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2025

## What is GHSA-fmh4-wr37-44fp?

GHSA-fmh4-wr37-44fp is an unsafe deserialization vulnerability in @vitejs/plugin-rsc, published on 3 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Summary

`@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained an unauthenticated remote code execution vulnerability in versions prior to 19.0.1, 19.1.2, and 19.2.1. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-fv66-9v8q-g76r

### Impact

Applications using affected versions of `@vitejs/plugin-rsc` are vulnerable to unauthenticated remote code execution through deserialization of untrusted data. An attacker can execute arbitrary code remotely without authentication, affecting confidentiality, integrity, and availability.

### Recommendations

Upgrade immediately to `@vitejs/plugin-rsc@0.5.3` or later.

### Workarounds

Applications not using server-side React or React Server Components are unaffected.

## Which versions are affected by GHSA-fmh4-wr37-44fp?

2 open source packages ship an affected version, including @vitejs/plugin-rsc.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@vitejs/plugin-rsc` | npm | All versions | 0.5.3 |
| `@vitejs/plugin-rsc` | npm | All versions | 0.5.3 |

## How do I fix GHSA-fmh4-wr37-44fp?

Upgrade @vitejs/plugin-rsc to 0.5.3 or later.

## Is GHSA-fmh4-wr37-44fp being exploited?

There is no known exploitation of GHSA-fmh4-wr37-44fp in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-fmh4-wr37-44fp and fix it if it is affected.

What it is: GHSA-fmh4-wr37-44fp is an unsafe deserialization vulnerability in @vitejs/plugin-rsc, published on 3 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-fmh4-wr37-44fp in the wild and no public exploit code.

Affected packages and fixed versions:
- @vitejs/plugin-rsc (npm): affected all versions; fixed in 0.5.3
- @vitejs/plugin-rsc (npm): affected all versions; fixed in 0.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-fmh4-wr37-44fp/ (Markdown: https://insights.sbomify.com/GHSA-fmh4-wr37-44fp/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-fmh4-wr37-44fp

---
From sbomify Insights: https://insights.sbomify.com/GHSA-fmh4-wr37-44fp/
Summaries are generated and may contain mistakes; the official description above is the record.
