{"answers":{"affected":"3 open source packages ship an affected version, including ntru.","exploited":"There is no known exploitation of GHSA-fq33-vmhv-48xh in the wild and no public exploit code.","fix":"No fix has been published for GHSA-fq33-vmhv-48xh yet. Limit exposure of the affected software until one is available.","what":"GHSA-fq33-vmhv-48xh is a memory corruption vulnerability in ntru, published on 22 Mar 2023."},"fix_prompt":"Check this codebase for GHSA-fq33-vmhv-48xh and fix it if it is affected.\n\nWhat it is: GHSA-fq33-vmhv-48xh is a memory corruption vulnerability in ntru, published on 22 Mar 2023. \nExploitation: There is no known exploitation of GHSA-fq33-vmhv-48xh in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ntru (crates.io): affected from 0.0.0-0; no fix listed\n- ntru (crates.io): affected from 0.4.3 up to 0.5.6; no fix listed\n- ntru (crates.io): affected from 0.4.3 up to 0.5.6; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-fq33-vmhv-48xh/ (Markdown: https://insights.sbomify.com/GHSA-fq33-vmhv-48xh/index.md)","id":"GHSA-fq33-vmhv-48xh","markdown":"https://insights.sbomify.com/GHSA-fq33-vmhv-48xh/index.md","name":"GHSA-fq33-vmhv-48xh","record":{"aliases":["RUSTSEC-2023-0032"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"unknown","non_default_config":false,"product_category":"Rust NTRU library","requires_auth":"none","summary":"Incorrect API usage in ntru-rs causes memory corruption, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The following usage causes undefined behavior.\n```rust\nlet kp: ntru::types::KeyPair = …;\nkp.get_public().export(Default::default())\n```\n\nWhen compiled with debug assertions, the code above will trigger a `attempt to subtract with overflow` panic before UB occurs.\nOther mistakes (e.g. using `EncParams` from a different key) may always trigger UB.\n\nLikely, older versions of this crate are also affected, but have not been tested.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":false,"headline":"ntru-rs has unsound FFI: Wrong API usage causes write past allocated area","id":"GHSA-fq33-vmhv-48xh","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":[],"introduced":["0.0.0-0"],"last_affected":[],"package":"ntru","purl":"pkg:cargo/ntru","source":"RUSTSEC-2023-0032"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.4.3"],"last_affected":["0.5.6"],"package":"ntru","purl":null,"source":"GHSA-fq33-vmhv-48xh"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.4.3"],"last_affected":["0.5.6"],"package":"ntru","purl":"pkg:cargo/ntru","source":"GHSA-fq33-vmhv-48xh"}],"products":null,"published":"2023-03-22","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Incorrect API usage in ntru-rs causes memory corruption, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/GHSA-fq33-vmhv-48xh/"}