GHSA-frm9-7pm9-5rgc SilverStripe comments module includes version of jQuery vulnerable to Cross-site Scripting
Outdated jQuery in SilverStripe comments module and themes allows XSS if user input is mishandled, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is GHSA-frm9-7pm9-5rgc?
GHSA-frm9-7pm9-5rgc is a cross-site scripting vulnerability in silverstripe/comments, published on 27 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The silverstripe/comments module, the cwp/starter-theme and the cwp/watea-theme include an outdated version of jQuery by default, which contains XSS vulnerabilities if user input is used in certain contexts. Though no known exploit has been found for these in the existing usage, user customisation to these themes could have made them exploitable.
CWP 2.0.0 has been released with the fixed cwp/stater-theme and silverstripe/comments module, and SilverStripe 4.2.0 will be released with the fixed silverstripe-themes/simple theme.
Which versions are affected by GHSA-frm9-7pm9-5rgc?
2 open source packages ship an affected version, including silverstripe/comments.
| Package | Affected | Fixed in |
|---|---|---|
silverstripe/comments Packagist | From 1.3.0 | 3.1.1 |
silverstripe/comments Packagist | From 1.3.0 | 3.1.1 |
How do I fix GHSA-frm9-7pm9-5rgc?
Upgrade silverstripe/comments to 3.1.1 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is GHSA-frm9-7pm9-5rgc being exploited?
There is no known exploitation of GHSA-frm9-7pm9-5rgc in the wild and no public exploit code.