{"answers":{"affected":"2 open source packages ship an affected version, including silverstripe/comments.","exploited":"There is no known exploitation of GHSA-frm9-7pm9-5rgc in the wild and no public exploit code.","fix":"Upgrade silverstripe/comments to 3.1.1 or later.","what":"GHSA-frm9-7pm9-5rgc is a cross-site scripting vulnerability in silverstripe/comments, published on 27 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-frm9-7pm9-5rgc and fix it if it is affected.\n\nWhat it is: GHSA-frm9-7pm9-5rgc is a cross-site scripting vulnerability in silverstripe/comments, published on 27 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-frm9-7pm9-5rgc in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- silverstripe/comments (Packagist): affected from 1.3.0; fixed in 3.1.1\n- silverstripe/comments (Packagist): affected from 1.3.0; fixed in 3.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-frm9-7pm9-5rgc/ (Markdown: https://insights.sbomify.com/GHSA-frm9-7pm9-5rgc/index.md)","id":"GHSA-frm9-7pm9-5rgc","markdown":"https://insights.sbomify.com/GHSA-frm9-7pm9-5rgc/index.md","name":"GHSA-frm9-7pm9-5rgc","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"SilverStripe comments module","requires_auth":"none","summary":"Outdated jQuery in SilverStripe comments module and themes allows XSS if user input is mishandled, requiring an upgrade to patched versions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The silverstripe/comments module, the cwp/starter-theme and the cwp/watea-theme include an outdated version of jQuery by default, which contains XSS vulnerabilities if user input is used in certain contexts. Though no known exploit has been found for these in the existing usage, user customisation to these themes could have made them exploitable.\n\nCWP 2.0.0 has been released with the fixed cwp/stater-theme and silverstripe/comments module, and SilverStripe 4.2.0 will be released with the fixed silverstripe-themes/simple theme.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"SilverStripe comments module includes version of jQuery vulnerable to Cross-site Scripting","id":"GHSA-frm9-7pm9-5rgc","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["3.1.1"],"introduced":["1.3.0"],"last_affected":[],"package":"silverstripe/comments","purl":null,"source":"GHSA-frm9-7pm9-5rgc"},{"ecosystem":"Packagist","fixed":["3.1.1"],"introduced":["1.3.0"],"last_affected":[],"package":"silverstripe/comments","purl":"pkg:composer/silverstripe/comments","source":"GHSA-frm9-7pm9-5rgc"}],"products":null,"published":"2024-05-27","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Outdated jQuery in SilverStripe comments module and themes allows XSS if user input is mishandled, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/GHSA-frm9-7pm9-5rgc/"}