{"answers":{"affected":"2 open source packages ship an affected version, including sequelize.","exploited":"There is no known exploitation of GHSA-fw4p-36j9-rrj3 in the wild and no public exploit code.","fix":"Upgrade sequelize to 4.44.4 or later.","what":"GHSA-fw4p-36j9-rrj3 is a denial of service vulnerability in sequelize, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-fw4p-36j9-rrj3 and fix it if it is affected.\n\nWhat it is: GHSA-fw4p-36j9-rrj3 is a denial of service vulnerability in sequelize, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-fw4p-36j9-rrj3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sequelize (npm): affected all versions; fixed in 4.44.4\n- sequelize (npm): affected all versions; fixed in 4.44.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-fw4p-36j9-rrj3/ (Markdown: https://insights.sbomify.com/GHSA-fw4p-36j9-rrj3/index.md)","id":"GHSA-fw4p-36j9-rrj3","markdown":"https://insights.sbomify.com/GHSA-fw4p-36j9-rrj3/index.md","name":"GHSA-fw4p-36j9-rrj3","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js ORM library","requires_auth":"none","summary":"Attackers can crash the Node.js process by submitting specific input to the SQLite dialect in Sequelize, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `sequelize` prior to 4.44.4 are vulnerable to Denial of Service (DoS). The SQLite dialect fails to catch a `TypeError` exception for the `results` variable. The `results` value may be undefined and trigger the error on a `.map` call. This may allow attackers to submit malicious input that forces the exception and crashes the Node process.  \n\nThe following proof-of-concept crashes the Node process:  \n```\nconst Sequelize = require('sequelize');\n\nconst sequelize = new Sequelize({\n\tdialect: 'sqlite',\n\tstorage: 'database.sqlite'\n});\n\nconst TypeError = sequelize.define('TypeError', {\n\tname: Sequelize.STRING,\n});\n\nTypeError.sync({force: true}).then(() =\u003e {\n\treturn TypeError.create({name: \"SELECT tbl_name FROM sqlite_master\"});\n});\n```\n\n## Recommendation\n\nUpgrade to version 4.44.4 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Denial of Service in sequelize","id":"GHSA-fw4p-36j9-rrj3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["4.44.4"],"introduced":["0"],"last_affected":[],"package":"sequelize","purl":null,"source":"GHSA-fw4p-36j9-rrj3"},{"ecosystem":"npm","fixed":["4.44.4"],"introduced":["0"],"last_affected":[],"package":"sequelize","purl":"pkg:npm/sequelize","source":"GHSA-fw4p-36j9-rrj3"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can crash the Node.js process by submitting specific input to the SQLite dialect in Sequelize, causing a denial of service.","url":"https://insights.sbomify.com/GHSA-fw4p-36j9-rrj3/"}