{"answers":{"affected":"3 open source packages ship an affected version, including rustyscript.","exploited":"There is no known exploitation of GHSA-fwfx-rrv8-crpf in the wild and no public exploit code.","fix":"Upgrade rustyscript to 0.6.1 or later.","what":"GHSA-fwfx-rrv8-crpf is a denial of service vulnerability in rustyscript, published on 18 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-fwfx-rrv8-crpf and fix it if it is affected.\n\nWhat it is: GHSA-fwfx-rrv8-crpf is a denial of service vulnerability in rustyscript, published on 18 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-fwfx-rrv8-crpf in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rustyscript (crates.io): affected from 0.3.1-0; fixed in 0.6.1\n- rustyscript (crates.io): affected from 0.4.0; fixed in 0.6.1\n- rustyscript (crates.io): affected from 0.4.0; fixed in 0.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-fwfx-rrv8-crpf/ (Markdown: https://insights.sbomify.com/GHSA-fwfx-rrv8-crpf/index.md)","id":"GHSA-fwfx-rrv8-crpf","markdown":"https://insights.sbomify.com/GHSA-fwfx-rrv8-crpf/index.md","name":"GHSA-fwfx-rrv8-crpf","record":{"aliases":["RUSTSEC-2024-0405"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Deno core library","requires_auth":"none","summary":"An exposed panic operation in the Deno core library allows attackers to crash the host thread, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Affected versions use deno_core releases that expose `Deno.core.ops.op_panic` to the JS runtime in the base core\n\nThis function when called triggers a manual panic in the thread containing the runtime.\n\nIt can be fixed by stubbing out the exposed op:\n```javascript\nDeno.core.ops.op_panic = (msg) =\u003e { throw new Error(msg) };\n```","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"op_panic in the base runtime can force a panic in the runtime's containing thread","id":"GHSA-fwfx-rrv8-crpf","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.6.1"],"introduced":["0.3.1-0"],"last_affected":[],"package":"rustyscript","purl":"pkg:cargo/rustyscript","source":"RUSTSEC-2024-0405"},{"ecosystem":"crates.io","fixed":["0.6.1"],"introduced":["0.4.0"],"last_affected":[],"package":"rustyscript","purl":null,"source":"GHSA-fwfx-rrv8-crpf"},{"ecosystem":"crates.io","fixed":["0.6.1"],"introduced":["0.4.0"],"last_affected":[],"package":"rustyscript","purl":"pkg:cargo/rustyscript","source":"GHSA-fwfx-rrv8-crpf"}],"products":null,"published":"2024-07-18","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An exposed panic operation in the Deno core library allows attackers to crash the host thread, causing a denial of service.","url":"https://insights.sbomify.com/GHSA-fwfx-rrv8-crpf/"}