# GHSA-fx5p-f64h-93xc: Opened exploitable ports in default docker-compose.yaml in go-ipfs

> Default Docker configuration exposes the IPFS admin API to the public network, allowing unauthorized access to node management functions.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2022
- **Also known as:** GO-2022-0418

## What is GHSA-fx5p-f64h-93xc?

GHSA-fx5p-f64h-93xc is a vulnerability in github.com/ipfs/go-ipfs, published on 4 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact

Allows admin API access to the IPFS node.

### Who ?

This affects people running the  [docker-compose.yaml](https://github.com/ipfs/go-ipfs/blob/master/docker-compose.yaml) service in an environment where the docker host is directly attached to a public or untrusted IP.  In the vulnerable version, the private API endpoint is publicly forwarded by exposing it as `0.0.0.0:5001` on the host machine.  

If the host machine is hidden behind a firewall or NAT (and the LAN is trusted for NAT), this is not an immediate issue because of the protection from the firewall or NAT.  That said, we still recommend users update to follow security best practices of not putting unnecessary dependency on a working firewall.

### Patches
This issue is in [docker-compose.yaml](https://github.com/ipfs/go-ipfs/blob/master/docker-compose.yaml).  Users need to replace their current `docker-compose.yaml` file with a version `0.12.1` or later.

There is no need to update any of the binaries. Users running previous versions like `0.12.0` or earlier can download the `0.12.1` `docker-compose.yaml` file.  You can replace a vulnerable `docker-compose.yaml` file with a the new one with:

```
curl https://raw.githubusercontent.com/ipfs/go-ipfs/v0.12.1/docker-compose.yaml > docker-compose.yaml
```

### How to test if you are vulnerable
#### Binding check on the host
On the host machine, while IPFS is running, run as root:

```bash
netstat -lnp | grep ":5001"
```

The output will be a list of listeners bound to `:5001`.
You then need to check that those listeners are private and preferably even localhost IPs.
⚠️ If this listener is on `0.0.0.0` or a public IP you are very likely vulnerable.

#### Remote hailing
While IPFS is running, you can try to contact the API from a remote machine. (Replace `1.2.3.4` with your node public IP.  Or if you want to test in an untrusted NAT, then substitute the LAN IP instead.)

```bash
curl -X POST http://1.2.3.4:5001/api/v0/version
```

⚠️ If you see any json outputted (e.g.,  `{"Commit": "<string>","Golang": "<string>","Repo": "<string>","System": "<string>","Version": "<string>"}`), then you are vulnerable.

If it **fails**, then you are safe.

### For more information
If you have any questions or comments about this advisory:
* Please first read https://docs.ipfs.io/reference/http/api/ about best practices
* Ask in [IPFS Discord #ipfs-chatter](https://discord.gg/ipfs)
* Open an issue in [go-ipfs](https://github.com/ipfs/go-ipfs)

## Which versions are affected by GHSA-fx5p-f64h-93xc?

3 open source packages ship an affected version, including github.com/ipfs/go-ipfs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ipfs/go-ipfs` | Go | From 0.11.0 | 0.12.1 |
| `github.com/ipfs/go-ipfs` | Go | From 0.11.0 | 0.12.1 |
| `github.com/ipfs/go-ipfs` | Go | From 0.11.0 | 0.12.1 |

## How do I fix GHSA-fx5p-f64h-93xc?

Upgrade github.com/ipfs/go-ipfs to 0.12.1 or later.

## Is GHSA-fx5p-f64h-93xc being exploited?

There is no known exploitation of GHSA-fx5p-f64h-93xc in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-fx5p-f64h-93xc and fix it if it is affected.

What it is: GHSA-fx5p-f64h-93xc is a vulnerability in github.com/ipfs/go-ipfs, published on 4 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-fx5p-f64h-93xc in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ipfs/go-ipfs (Go): affected from 0.11.0; fixed in 0.12.1
- github.com/ipfs/go-ipfs (Go): affected from 0.11.0; fixed in 0.12.1
- github.com/ipfs/go-ipfs (Go): affected from 0.11.0; fixed in 0.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-fx5p-f64h-93xc/ (Markdown: https://insights.sbomify.com/GHSA-fx5p-f64h-93xc/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-fx5p-f64h-93xc

---
From sbomify Insights: https://insights.sbomify.com/GHSA-fx5p-f64h-93xc/
Summaries are generated and may contain mistakes; the official description above is the record.
