GHSA-fxq4-r6mr-9x64 CSRF Vuln can expose user's QRcode
A CSRF vulnerability allows attackers to steal two-factor authentication QR codes during user setup, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is GHSA-fxq4-r6mr-9x64?
GHSA-fxq4-r6mr-9x64 is a vulnerability in Flask-Security-Too, published on 8 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Impact
When a user is setting up two-factor authentication using an authenticator app, a QRcode is generated and made available via a GET request to /tf-qrcode. Since GETs do not have any CSRF protection, it is possible a malicious 3rd party could access the QRcode and therefore gain access to two-factor authentication codes. Note that the /tf-qrcode endpoint is ONLY accessible while the user is initially setting up their device. Once setup is complete, there is no vulnerability.
Patches
This is fixed in the upcoming 4.0.0 release.
Workarounds
You can provide your own URL for fetching the QRcode by defining SECURITY_TWO_FACTOR_QRCODE_URL and providing your own implementation (that presumably required a POST with CSRF protection). This would require changing the two-factor setup template as well.
References
None.
For more information
If you have any questions or comments about this advisory:
- Read this pull request: #423
Which versions are affected by GHSA-fxq4-r6mr-9x64?
2 open source packages ship an affected version, including Flask-Security-Too and flask-security-too.
| Package | Affected | Fixed in |
|---|---|---|
Flask-Security-Too PyPI | From 3.2.0 | 3.4.5 |
flask-security-too PyPI | From 3.2.0 | 3.4.5 |
How do I fix GHSA-fxq4-r6mr-9x64?
Upgrade Flask-Security-Too to 3.4.5 or later.
Is GHSA-fxq4-r6mr-9x64 being exploited?
There is no known exploitation of GHSA-fxq4-r6mr-9x64 in the wild and no public exploit code.