# GHSA-fxq4-r6mr-9x64: CSRF Vuln can expose user's QRcode

> A CSRF vulnerability allows attackers to steal two-factor authentication QR codes during user setup, potentially leading to account takeover.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Apr 2021

## What is GHSA-fxq4-r6mr-9x64?

GHSA-fxq4-r6mr-9x64 is a vulnerability in Flask-Security-Too, published on 8 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

### Impact
When a user is setting up two-factor authentication using an authenticator app, a QRcode is generated and made available via a GET request to /tf-qrcode. Since GETs do not have any CSRF protection, it is possible a malicious 3rd party could access the QRcode and therefore gain access to two-factor authentication codes. Note that the /tf-qrcode endpoint is ONLY accessible while the user is initially setting up their device. Once setup is complete, there is no vulnerability.

### Patches
This is fixed in the upcoming 4.0.0 release.

### Workarounds
You can provide your own URL for fetching the QRcode by defining SECURITY_TWO_FACTOR_QRCODE_URL and providing your own implementation (that presumably required a POST with CSRF protection). This would require changing the two-factor setup template as well.

### References
None.

### For more information
If you have any questions or comments about this advisory:
* Read this pull request: #423

## Which versions are affected by GHSA-fxq4-r6mr-9x64?

2 open source packages ship an affected version, including Flask-Security-Too and flask-security-too.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Flask-Security-Too` | PyPI | From 3.2.0 | 3.4.5 |
| `flask-security-too` | PyPI | From 3.2.0 | 3.4.5 |

## How do I fix GHSA-fxq4-r6mr-9x64?

Upgrade Flask-Security-Too to 3.4.5 or later.

## Is GHSA-fxq4-r6mr-9x64 being exploited?

There is no known exploitation of GHSA-fxq4-r6mr-9x64 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-fxq4-r6mr-9x64 and fix it if it is affected.

What it is: GHSA-fxq4-r6mr-9x64 is a vulnerability in Flask-Security-Too, published on 8 Apr 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-fxq4-r6mr-9x64 in the wild and no public exploit code.

Affected packages and fixed versions:
- Flask-Security-Too (PyPI): affected from 3.2.0; fixed in 3.4.5
- flask-security-too (PyPI): affected from 3.2.0; fixed in 3.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-fxq4-r6mr-9x64/ (Markdown: https://insights.sbomify.com/GHSA-fxq4-r6mr-9x64/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-fxq4-r6mr-9x64

---
From sbomify Insights: https://insights.sbomify.com/GHSA-fxq4-r6mr-9x64/
Summaries are generated and may contain mistakes; the official description above is the record.
