# GHSA-g2gp-3wwq-f4ph: league/commonmark: Denial of service via adjacent inline attribute blocks

> An unauthenticated attacker can cause denial of service via quadratic time complexity in the Attributes extension of the league/commonmark library.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2026

## What is GHSA-g2gp-3wwq-f4ph?

GHSA-g2gp-3wwq-f4ph is a denial of service vulnerability in league/commonmark, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact

With the Attributes extension enabled, `AttributesListener::findTargetAndDirection()` resolves each attribute node's target by walking outward through its siblings. For a run of N adjacent inline attribute blocks placed at the start of a block (with nothing to their left), each node scans the **entire** sibling list to the far-right end before giving up and falling back to the parent. Each resolution is therefore Θ(N) and the whole run is **Θ(N²)**.

Reaching the path requires `AttributesExtension` (opt-in, but first-party: `League\CommonMark\Extension\Attributes\AttributesExtension`). No other configuration matters — the quadratic walk runs unconditionally during parsing and is **not** gated by the `attributes/allow` allow-list, the `on*` hardening added in 2.7.0, or `allow_unsafe_links`. An unauthenticated attacker can submit a **~32 KB** input (`{#a}` repeated 8,000 times) that takes **over 5 seconds** to convert, with time growing quadratically in input length — a cheap denial of service. Availability impact only. **The Attributes extension was introduced in 1.5.0 (May 2020) with this outward-walk resolver present from the first commit, so all releases from 1.5.0 onward (including every 2.x) are affected.**

### Workarounds

There is no library-level configuration that gates the quadratic walk. Integrators who cannot upgrade can only reduce exposure indirectly:

- **Disable the Attributes extension** for untrusted input, or
- **Impose a strict maximum input length before conversion** — noting that because the cost is quadratic, even a modest cap must be small to meaningfully bound worst-case CPU.

Upgrading to a release containing the fix is recommended.

## Which versions are affected by GHSA-g2gp-3wwq-f4ph?

2 open source packages ship an affected version, including league/commonmark.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `league/commonmark` | Packagist | From 1.5.0 | 2.9.0 |
| `league/commonmark` | Packagist | From 1.5.0 | 2.9.0 |

## How do I fix GHSA-g2gp-3wwq-f4ph?

Upgrade league/commonmark to 2.9.0 or later.

## Is GHSA-g2gp-3wwq-f4ph being exploited?

There is no known exploitation of GHSA-g2gp-3wwq-f4ph in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-g2gp-3wwq-f4ph and fix it if it is affected.

What it is: GHSA-g2gp-3wwq-f4ph is a denial of service vulnerability in league/commonmark, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-g2gp-3wwq-f4ph in the wild and no public exploit code.

Affected packages and fixed versions:
- league/commonmark (Packagist): affected from 1.5.0; fixed in 2.9.0
- league/commonmark (Packagist): affected from 1.5.0; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-g2gp-3wwq-f4ph/ (Markdown: https://insights.sbomify.com/GHSA-g2gp-3wwq-f4ph/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-g2gp-3wwq-f4ph

---
From sbomify Insights: https://insights.sbomify.com/GHSA-g2gp-3wwq-f4ph/
Summaries are generated and may contain mistakes; the official description above is the record.
