{"answers":{"affected":"2 open source packages ship an affected version, including swagger-ui.","exploited":"There is no known exploitation of GHSA-g336-c7wv-8hp3 in the wild and no public exploit code.","fix":"Upgrade swagger-ui to 2.2.1 or later.","what":"GHSA-g336-c7wv-8hp3 is a cross-site scripting vulnerability in swagger-ui, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-g336-c7wv-8hp3 and fix it if it is affected.\n\nWhat it is: GHSA-g336-c7wv-8hp3 is a cross-site scripting vulnerability in swagger-ui, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-g336-c7wv-8hp3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- swagger-ui (npm): affected all versions; fixed in 2.2.1\n- swagger-ui (npm): affected all versions; fixed in 2.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-g336-c7wv-8hp3/ (Markdown: https://insights.sbomify.com/GHSA-g336-c7wv-8hp3/index.md)","id":"GHSA-g336-c7wv-8hp3","markdown":"https://insights.sbomify.com/GHSA-g336-c7wv-8hp3/index.md","name":"GHSA-g336-c7wv-8hp3","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Swagger UI library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in victim browsers via the url parameter in Swagger UI, requiring user interaction.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Affected versions of `swagger-ui` are vulnerable to cross-site scripting via the `url` query string parameter.\n\n## Recommendation\n\nUpdate to 2.2.1 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in swagger-ui","id":"GHSA-g336-c7wv-8hp3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"swagger-ui","purl":null,"source":"GHSA-g336-c7wv-8hp3"},{"ecosystem":"npm","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"swagger-ui","purl":"pkg:npm/swagger-ui","source":"GHSA-g336-c7wv-8hp3"}],"products":null,"published":"2020-09-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary scripts in victim browsers via the url parameter in Swagger UI, requiring user interaction.","url":"https://insights.sbomify.com/GHSA-g336-c7wv-8hp3/"}