{"answers":{"affected":"2 open source packages ship an affected version, including zendframework/zendframework1.","exploited":"There is no known exploitation of GHSA-g52p-86j5-xr8q in the wild and no public exploit code.","fix":"Upgrade zendframework/zendframework1 to 1.11.4 or later.","what":"GHSA-g52p-86j5-xr8q is a cross-site scripting vulnerability in zendframework/zendframework1, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-g52p-86j5-xr8q and fix it if it is affected.\n\nWhat it is: GHSA-g52p-86j5-xr8q is a cross-site scripting vulnerability in zendframework/zendframework1, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-g52p-86j5-xr8q in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zendframework1 (Packagist): affected from 1.0.0; fixed in 1.11.4\n- zendframework/zendframework1 (Packagist): affected from 1.0.0; fixed in 1.11.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-g52p-86j5-xr8q/ (Markdown: https://insights.sbomify.com/GHSA-g52p-86j5-xr8q/index.md)","id":"GHSA-g52p-86j5-xr8q","markdown":"https://insights.sbomify.com/GHSA-g52p-86j5-xr8q/index.md","name":"GHSA-g52p-86j5-xr8q","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Zend Framework","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in a victim's browser via unescaped parameters in development mode error views.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The default error handling view script generated using `Zend_Tool` failed to escape request parameters when run in the \"development\" configuration environment, providing a potential XSS attack vector.\n\n`Zend_Tool_Project_Context_Zf_ViewScriptFile` was patched such that the view script template now calls the `escape()` method on dumped request variables.\n\nZend Framework 1.11.4 includes a patch that adds escaping to the generated error/error.phtml view script, ensuring that request variables are escaped appropriately for the browser.\nDo note, however, that this will not update any previously generated code. You will still need to follow the next advice for previously generated error view scripts.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"ZendFramework Potential Cross-site Scripting in Development Environment Error View Script","id":"GHSA-g52p-86j5-xr8q","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.11.4"],"introduced":["1.0.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":null,"source":"GHSA-g52p-86j5-xr8q"},{"ecosystem":"Packagist","fixed":["1.11.4"],"introduced":["1.0.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":"pkg:composer/zendframework/zendframework1","source":"GHSA-g52p-86j5-xr8q"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can execute arbitrary scripts in a victim's browser via unescaped parameters in development mode error views.","url":"https://insights.sbomify.com/GHSA-g52p-86j5-xr8q/"}