GHSA-g5p6-327m-3fxx Talos Linux ships runc vulnerable to the escape to the host attack
Attackers can escape containers to the host OS via malicious images or Dockerfiles, requiring Talos Linux administrators to upgrade runc.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-g5p6-327m-3fxx?
GHSA-g5p6-327m-3fxx is a vulnerability in github.com/siderolabs/talos, published on 2 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Impact
Snyk has discovered a vulnerability in all versions of runc <=1.1.11, as used by the Docker engine, along with other containerization technologies such as Kubernetes. Exploitation of this issue can result in container escape to the underlying host OS, either through executing a malicious image or building an image using a malicious Dockerfile or upstream image (i.e., when using FROM). This issue has been assigned the CVE-2024-21626.
Patches
runc runtime was updated to 1.1.12 in Talos v1.5.6 and v1.6.4.
Workarounds
Inspect the workloads running on the cluster to make sure they are not trying to exploit the vulnerability.
References
Which versions are affected by GHSA-g5p6-327m-3fxx?
4 open source packages ship an affected version, including github.com/siderolabs/talos.
| Package | Affected | Fixed in |
|---|---|---|
github.com/siderolabs/talos Go | All versions | 1.5.6 |
github.com/siderolabs/talos Go | All versions | 1.5.6 |
github.com/siderolabs/talos Go | From 1.6.0 | 1.6.4 |
github.com/siderolabs/talos Go | From 1.6.0 | 1.6.4 |
How do I fix GHSA-g5p6-327m-3fxx?
Upgrade github.com/siderolabs/talos to a fixed version for your release line: 1.5.6 or 1.6.4.
Is GHSA-g5p6-327m-3fxx being exploited?
There is no known exploitation of GHSA-g5p6-327m-3fxx in the wild and no public exploit code.