{"answers":{"affected":"2 open source packages ship an affected version, including symbiote/silverstripe-multivaluefield.","exploited":"There is no known exploitation of GHSA-g5vj-wj9x-4jg9 in the wild and no public exploit code.","fix":"Upgrade symbiote/silverstripe-multivaluefield to 3.1.0 or later.","what":"GHSA-g5vj-wj9x-4jg9 is an unsafe deserialization vulnerability in symbiote/silverstripe-multivaluefield, published on 29 May 2024. It can be exploited over the network."},"fix_prompt":"Check this codebase for GHSA-g5vj-wj9x-4jg9 and fix it if it is affected.\n\nWhat it is: GHSA-g5vj-wj9x-4jg9 is an unsafe deserialization vulnerability in symbiote/silverstripe-multivaluefield, published on 29 May 2024. It can be exploited over the network.\nExploitation: There is no known exploitation of GHSA-g5vj-wj9x-4jg9 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- symbiote/silverstripe-multivaluefield (Packagist): affected from 3.0.0; fixed in 3.1.0\n- symbiote/silverstripe-multivaluefield (Packagist): affected from 3.0.0; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-g5vj-wj9x-4jg9/ (Markdown: https://insights.sbomify.com/GHSA-g5vj-wj9x-4jg9/index.md)","id":"GHSA-g5vj-wj9x-4jg9","markdown":"https://insights.sbomify.com/GHSA-g5vj-wj9x-4jg9/index.md","name":"GHSA-g5vj-wj9x-4jg9","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"SilverStripe plugin","requires_auth":"unknown","summary":"An attacker can exploit PHP object injection and XSS vulnerabilities in the SilverStripe multivalue field plugin to execute code or bypass security controls.","user_interaction":"unknown","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A potential deserialisation vulnerability has been identified in the symbiote/silverstripe-multivaluefield which could allow an attacker to exploit implementations of this module via object injection.\n\nSupport for handling PHP objects as values in this module has been deprecated, and the serialisation technique has been switched to using JSON for handling arrays.\n\nAs well as this, a potential XSS (cross-site scripting) vulnerability has been identified and remediated.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"symbiote/silverstripe-multivaluefield Possible PHP Object Injection via Multi-Value Field Extension","id":"GHSA-g5vj-wj9x-4jg9","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["3.1.0"],"introduced":["3.0.0"],"last_affected":[],"package":"symbiote/silverstripe-multivaluefield","purl":null,"source":"GHSA-g5vj-wj9x-4jg9"},{"ecosystem":"Packagist","fixed":["3.1.0"],"introduced":["3.0.0"],"last_affected":[],"package":"symbiote/silverstripe-multivaluefield","purl":"pkg:composer/symbiote/silverstripe-multivaluefield","source":"GHSA-g5vj-wj9x-4jg9"}],"products":null,"published":"2024-05-29","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can exploit PHP object injection and XSS vulnerabilities in the SilverStripe multivalue field plugin to execute code or bypass security controls.","url":"https://insights.sbomify.com/GHSA-g5vj-wj9x-4jg9/"}