GHSA-g74r-ffvr-5q9f Memory Exposure in concat-stream
Attackers can expose memory contents by passing numeric input to the write function in concat-stream, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-g74r-ffvr-5q9f?
GHSA-g74r-ffvr-5q9f is a vulnerability in concat-stream, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Versions of concat-stream before 1.5.2 are vulnerable to memory exposure if userp provided input is passed into write()
Versions <1.3.0 are not affected due to not using unguarded Buffer constructor.
Recommendation
Update to version 1.5.2, 1.4.11, 1.3.2 or later.
If you are unable to update make sure user provided input into the write() function is not a number.
Which versions are affected by GHSA-g74r-ffvr-5q9f?
6 open source packages ship an affected version, including concat-stream.
| Package | Affected | Fixed in |
|---|---|---|
concat-stream npm | From 1.3.0 | 1.3.2 |
concat-stream npm | From 1.3.0 | 1.3.2 |
concat-stream npm | From 1.4.0 | 1.4.11 |
concat-stream npm | From 1.4.0 | 1.4.11 |
concat-stream npm | From 1.5.0 | 1.5.2 |
concat-stream npm | From 1.5.0 | 1.5.2 |
How do I fix GHSA-g74r-ffvr-5q9f?
Upgrade concat-stream to a fixed version for your release line: 1.3.2, 1.4.11 or 1.5.2.
Is GHSA-g74r-ffvr-5q9f being exploited?
There is no known exploitation of GHSA-g74r-ffvr-5q9f in the wild and no public exploit code.