{"answers":{"affected":"6 open source packages ship an affected version, including concat-stream.","exploited":"There is no known exploitation of GHSA-g74r-ffvr-5q9f in the wild and no public exploit code.","fix":"Upgrade concat-stream to a fixed version for your release line: 1.3.2, 1.4.11 or 1.5.2.","what":"GHSA-g74r-ffvr-5q9f is a vulnerability in concat-stream, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-g74r-ffvr-5q9f and fix it if it is affected.\n\nWhat it is: GHSA-g74r-ffvr-5q9f is a vulnerability in concat-stream, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-g74r-ffvr-5q9f in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- concat-stream (npm): affected from 1.3.0; fixed in 1.3.2\n- concat-stream (npm): affected from 1.3.0; fixed in 1.3.2\n- concat-stream (npm): affected from 1.4.0; fixed in 1.4.11\n- concat-stream (npm): affected from 1.4.0; fixed in 1.4.11\n- concat-stream (npm): affected from 1.5.0; fixed in 1.5.2\n- concat-stream (npm): affected from 1.5.0; fixed in 1.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-g74r-ffvr-5q9f/ (Markdown: https://insights.sbomify.com/GHSA-g74r-ffvr-5q9f/index.md)","id":"GHSA-g74r-ffvr-5q9f","markdown":"https://insights.sbomify.com/GHSA-g74r-ffvr-5q9f/index.md","name":"GHSA-g74r-ffvr-5q9f","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js stream library","requires_auth":"none","summary":"Attackers can expose memory contents by passing numeric input to the write function in concat-stream, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `concat-stream` before 1.5.2 are vulnerable to memory exposure if userp provided input is passed into `write()`\n\nVersions \u003c1.3.0 are not affected due to not using unguarded Buffer constructor.\n\n## Recommendation\n\nUpdate to version 1.5.2, 1.4.11, 1.3.2 or later.\n\nIf you are unable to update make sure user provided input into the `write()` function is not a number.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Memory Exposure in concat-stream","id":"GHSA-g74r-ffvr-5q9f","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2019"},"n_packages":6,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.3.2"],"introduced":["1.3.0"],"last_affected":[],"package":"concat-stream","purl":null,"source":"GHSA-g74r-ffvr-5q9f"},{"ecosystem":"npm","fixed":["1.3.2"],"introduced":["1.3.0"],"last_affected":[],"package":"concat-stream","purl":"pkg:npm/concat-stream","source":"GHSA-g74r-ffvr-5q9f"},{"ecosystem":"npm","fixed":["1.4.11"],"introduced":["1.4.0"],"last_affected":[],"package":"concat-stream","purl":null,"source":"GHSA-g74r-ffvr-5q9f"},{"ecosystem":"npm","fixed":["1.4.11"],"introduced":["1.4.0"],"last_affected":[],"package":"concat-stream","purl":"pkg:npm/concat-stream","source":"GHSA-g74r-ffvr-5q9f"},{"ecosystem":"npm","fixed":["1.5.2"],"introduced":["1.5.0"],"last_affected":[],"package":"concat-stream","purl":null,"source":"GHSA-g74r-ffvr-5q9f"},{"ecosystem":"npm","fixed":["1.5.2"],"introduced":["1.5.0"],"last_affected":[],"package":"concat-stream","purl":"pkg:npm/concat-stream","source":"GHSA-g74r-ffvr-5q9f"}],"products":null,"published":"2019-06-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can expose memory contents by passing numeric input to the write function in concat-stream, requiring an upgrade to fix.","url":"https://insights.sbomify.com/GHSA-g74r-ffvr-5q9f/"}