# GHSA-g74r-ffvr-5q9f: Memory Exposure in concat-stream

> Attackers can expose memory contents by passing numeric input to the write function in concat-stream, requiring an upgrade to fix.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2019

## What is GHSA-g74r-ffvr-5q9f?

GHSA-g74r-ffvr-5q9f is a vulnerability in concat-stream, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of `concat-stream` before 1.5.2 are vulnerable to memory exposure if userp provided input is passed into `write()`

Versions <1.3.0 are not affected due to not using unguarded Buffer constructor.

## Recommendation

Update to version 1.5.2, 1.4.11, 1.3.2 or later.

If you are unable to update make sure user provided input into the `write()` function is not a number.

## Which versions are affected by GHSA-g74r-ffvr-5q9f?

6 open source packages ship an affected version, including concat-stream.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concat-stream` | npm | From 1.3.0 | 1.3.2 |
| `concat-stream` | npm | From 1.3.0 | 1.3.2 |
| `concat-stream` | npm | From 1.4.0 | 1.4.11 |
| `concat-stream` | npm | From 1.4.0 | 1.4.11 |
| `concat-stream` | npm | From 1.5.0 | 1.5.2 |
| `concat-stream` | npm | From 1.5.0 | 1.5.2 |

## How do I fix GHSA-g74r-ffvr-5q9f?

Upgrade concat-stream to a fixed version for your release line: 1.3.2, 1.4.11 or 1.5.2.

## Is GHSA-g74r-ffvr-5q9f being exploited?

There is no known exploitation of GHSA-g74r-ffvr-5q9f in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-g74r-ffvr-5q9f and fix it if it is affected.

What it is: GHSA-g74r-ffvr-5q9f is a vulnerability in concat-stream, published on 3 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-g74r-ffvr-5q9f in the wild and no public exploit code.

Affected packages and fixed versions:
- concat-stream (npm): affected from 1.3.0; fixed in 1.3.2
- concat-stream (npm): affected from 1.3.0; fixed in 1.3.2
- concat-stream (npm): affected from 1.4.0; fixed in 1.4.11
- concat-stream (npm): affected from 1.4.0; fixed in 1.4.11
- concat-stream (npm): affected from 1.5.0; fixed in 1.5.2
- concat-stream (npm): affected from 1.5.0; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-g74r-ffvr-5q9f/ (Markdown: https://insights.sbomify.com/GHSA-g74r-ffvr-5q9f/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-g74r-ffvr-5q9f

---
From sbomify Insights: https://insights.sbomify.com/GHSA-g74r-ffvr-5q9f/
Summaries are generated and may contain mistakes; the official description above is the record.
