# GHSA-g8pg-33v4-9r96: Thelia authentication bypass vulnerability

> Attackers can bypass authentication to access customer and admin accounts in the Thelia e-commerce platform.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2024

## What is GHSA-g8pg-33v4-9r96?

GHSA-g8pg-33v4-9r96 is an authentication bypass vulnerability in thelia/thelia, published on 30 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An authentication bypass was identifed in thelia/thelia project for customer and admin. This vulnerability is present from version 2.0.0-beta1 and is fixed in 2.1.3 and 2.2.0-alpha1.

## Which versions are affected by GHSA-g8pg-33v4-9r96?

2 open source packages ship an affected version, including thelia/thelia.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thelia/thelia` | Packagist | From 2.0.0-beta1 | 2.1.3 |
| `thelia/thelia` | Packagist | From 2.0.0-beta1 | 2.1.3 |

## How do I fix GHSA-g8pg-33v4-9r96?

Upgrade thelia/thelia to 2.1.3 or later.

## Is GHSA-g8pg-33v4-9r96 being exploited?

There is no known exploitation of GHSA-g8pg-33v4-9r96 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-g8pg-33v4-9r96 and fix it if it is affected.

What it is: GHSA-g8pg-33v4-9r96 is an authentication bypass vulnerability in thelia/thelia, published on 30 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-g8pg-33v4-9r96 in the wild and no public exploit code.

Affected packages and fixed versions:
- thelia/thelia (Packagist): affected from 2.0.0-beta1; fixed in 2.1.3
- thelia/thelia (Packagist): affected from 2.0.0-beta1; fixed in 2.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-g8pg-33v4-9r96/ (Markdown: https://insights.sbomify.com/GHSA-g8pg-33v4-9r96/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-g8pg-33v4-9r96

---
From sbomify Insights: https://insights.sbomify.com/GHSA-g8pg-33v4-9r96/
Summaries are generated and may contain mistakes; the official description above is the record.
