{"answers":{"affected":"4 open source packages ship an affected version, including action_text-trix and trix.","exploited":"There is no known exploitation of GHSA-g9jg-w8vm-g96v in the wild and no public exploit code.","fix":"Upgrade action_text-trix to 2.1.16 or later.","what":"GHSA-g9jg-w8vm-g96v is a cross-site scripting vulnerability in action_text-trix, published on 31 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-g9jg-w8vm-g96v and fix it if it is affected.\n\nWhat it is: GHSA-g9jg-w8vm-g96v is a cross-site scripting vulnerability in action_text-trix, published on 31 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-g9jg-w8vm-g96v in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- action_text-trix (RubyGems): affected all versions; fixed in 2.1.16\n- action_text-trix (RubyGems): affected all versions; fixed in 2.1.16\n- trix (npm): affected all versions; fixed in 2.1.16\n- trix (npm): affected all versions; fixed in 2.1.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-g9jg-w8vm-g96v/ (Markdown: https://insights.sbomify.com/GHSA-g9jg-w8vm-g96v/index.md)","id":"GHSA-g9jg-w8vm-g96v","markdown":"https://insights.sbomify.com/GHSA-g9jg-w8vm-g96v/index.md","name":"GHSA-g9jg-w8vm-g96v","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Trix rich text editor","requires_auth":"low_privilege","summary":"Attackers can inject malicious JavaScript via attachment attributes in the Trix editor, leading to arbitrary code execution in user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThe Trix editor, in versions prior to 2.1.16, is vulnerable to XSS attacks through attachment payloads.\n\nAn attacker could inject malicious code into a data-trix-attachment attribute that, when rendered as HTML and clicked on, could execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed.\n\n### Patches\nUpdate Recommendation: Users should upgrade to Trix editor version 2.1.16 or later.\n\n### Resources\nThe XSS vulnerability was reported by HackerOne researcher [michaelcheers](https://hackerone.com/michaelcheers?type=user).","ecosystems":["RubyGems","npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Trix has a stored XSS vulnerability through its attachment attribute","id":"GHSA-g9jg-w8vm-g96v","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"RubyGems","fixed":["2.1.16"],"introduced":["0"],"last_affected":[],"package":"action_text-trix","purl":null,"source":"GHSA-g9jg-w8vm-g96v"},{"ecosystem":"RubyGems","fixed":["2.1.16"],"introduced":["0"],"last_affected":[],"package":"action_text-trix","purl":"pkg:gem/action_text-trix","source":"GHSA-g9jg-w8vm-g96v"},{"ecosystem":"npm","fixed":["2.1.16"],"introduced":["0"],"last_affected":[],"package":"trix","purl":null,"source":"GHSA-g9jg-w8vm-g96v"},{"ecosystem":"npm","fixed":["2.1.16"],"introduced":["0"],"last_affected":[],"package":"trix","purl":"pkg:npm/trix","source":"GHSA-g9jg-w8vm-g96v"}],"products":null,"published":"2025-12-31","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject malicious JavaScript via attachment attributes in the Trix editor, leading to arbitrary code execution in user sessions.","url":"https://insights.sbomify.com/GHSA-g9jg-w8vm-g96v/"}