{"answers":{"affected":"2 open source packages ship an affected version, including console-feed.","exploited":"There is no known exploitation of GHSA-g9wg-wq4f-2x5w in the wild and no public exploit code.","fix":"Upgrade console-feed to 2.8.10 or later.","what":"GHSA-g9wg-wq4f-2x5w is a cross-site scripting vulnerability in console-feed, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-g9wg-wq4f-2x5w and fix it if it is affected.\n\nWhat it is: GHSA-g9wg-wq4f-2x5w is a cross-site scripting vulnerability in console-feed, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-g9wg-wq4f-2x5w in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- console-feed (npm): affected all versions; fixed in 2.8.10\n- console-feed (npm): affected all versions; fixed in 2.8.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-g9wg-wq4f-2x5w/ (Markdown: https://insights.sbomify.com/GHSA-g9wg-wq4f-2x5w/index.md)","id":"GHSA-g9wg-wq4f-2x5w","markdown":"https://insights.sbomify.com/GHSA-g9wg-wq4f-2x5w/index.md","name":"GHSA-g9wg-wq4f-2x5w","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript logging library","requires_auth":"none","summary":"Cross-Site Scripting in console-feed allows attackers to execute arbitrary JavaScript via malicious console.log payloads.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `console-feed` prior to 2.8.10 are vulnerable to Cross-Site Scripting (XSS). The package fails to properly escape the rendered output. If an application uses `console-feed` and a malicious JavaScript payload was passed to a `console.log('%_', payload)` call, the package would render HTML containing the malicious payload.\n\n## Recommendation\n\nUpgrade to version 2.8.10 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in console-feed","id":"GHSA-g9wg-wq4f-2x5w","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.8.10"],"introduced":["0"],"last_affected":[],"package":"console-feed","purl":null,"source":"GHSA-g9wg-wq4f-2x5w"},{"ecosystem":"npm","fixed":["2.8.10"],"introduced":["0"],"last_affected":[],"package":"console-feed","purl":"pkg:npm/console-feed","source":"GHSA-g9wg-wq4f-2x5w"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Cross-Site Scripting in console-feed allows attackers to execute arbitrary JavaScript via malicious console.log payloads.","url":"https://insights.sbomify.com/GHSA-g9wg-wq4f-2x5w/"}