{"answers":{"affected":"2 open source packages ship an affected version, including openclaw.","exploited":"There is no known exploitation of GHSA-gfmx-pph7-g46x in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.4.8 or later.","what":"GHSA-gfmx-pph7-g46x is a code injection vulnerability in openclaw, published on 9 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-gfmx-pph7-g46x and fix it if it is affected.\n\nWhat it is: GHSA-gfmx-pph7-g46x is a code injection vulnerability in openclaw, published on 9 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-gfmx-pph7-g46x in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected all versions; fixed in 2026.4.8\n- openclaw (npm): affected all versions; fixed in 2026.4.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-gfmx-pph7-g46x/ (Markdown: https://insights.sbomify.com/GHSA-gfmx-pph7-g46x/index.md)","id":"GHSA-gfmx-pph7-g46x","markdown":"https://insights.sbomify.com/GHSA-gfmx-pph7-g46x/index.md","name":"GHSA-gfmx-pph7-g46x","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenClaw npm package","requires_auth":"none","summary":"Attackers can inject malicious prompts into trusted system events via lower-trust background output, potentially compromising agent execution.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Impact\n\nLower-trust background runtime output is injected into trusted `System:` events, and local async exec completion misses the intended `exec-event` downgrade.\n\nLower-trust runtime/background output could be promoted into trusted System events, allowing prompt-injection into later agent turns.\n\nOpenClaw is a user-controlled local assistant. This advisory is scoped to the OpenClaw trust model and does not assume a multi-tenant service boundary.\n\n## Affected Packages / Versions\n\n- Package: `openclaw` (npm)\n- Affected versions: `\u003c= 2026.4.2`\n- Patched versions: `2026.4.8`\n\n## Fix\n\nThe issue was fixed on `main` and is available in the patched npm version listed above. The verified fixed tree is commit `d7c3210cd6f5fdfdc1beff4c9541673e814354d5`.\n\n## Verification\n\nThe fix was re-checked against `main` before publication, including targeted regression tests for the affected security boundary.\n\n## Credits\n\nThanks @tdjackey for reporting.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Impact Lower-trust background runtime output is injected into trusted `System:` events, and local async exec completion misses the intend","id":"GHSA-gfmx-pph7-g46x","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2026.4.8"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-gfmx-pph7-g46x"},{"ecosystem":"npm","fixed":["2026.4.8"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-gfmx-pph7-g46x"}],"products":null,"published":"2026-04-09","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject malicious prompts into trusted system events via lower-trust background output, potentially compromising agent execution.","url":"https://insights.sbomify.com/GHSA-gfmx-pph7-g46x/"}