GHSA-ggpf-24jw-3fcw CVE-2025-24357 Malicious model remote code execution fix bypass with PyTorch < 2.6.0
Loading malicious models in vLLM with vulnerable PyTorch versions allows remote code execution via unsafe deserialization.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is GHSA-ggpf-24jw-3fcw?
GHSA-ggpf-24jw-3fcw is an unsafe deserialization vulnerability in vllm, published on 23 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Description
https://github.com/vllm-project/vllm/security/advisories/GHSA-rh4j-5rhw-hr54 reported a vulnerability where loading a malicious model could result in code execution on the vllm host. The fix applied to specify weights_only=True to calls to torch.load() did not solve the problem prior to PyTorch 2.6.0.
PyTorch has issued a new CVE about this problem: https://github.com/advisories/GHSA-53q9-r3pm-6pq6
This means that versions of vLLM using PyTorch before 2.6.0 are vulnerable to this problem.
Background Knowledge
When users install VLLM according to the official manual
But the version of PyTorch is specified in the requirements. txt file
So by default when the user install VLLM, it will install the PyTorch with version 2.5.1
In CVE-2025-24357, weights_only=True was used for patching, but we know this is not secure. Because we found that using Weights_only=True in pyTorch before 2.5.1 was unsafe
Here, we use this interface to prove that it is not safe.
Fix
update PyTorch version to 2.6.0
Credit
This vulnerability was found By Ji'an Zhou and Li'shuo Song
Which versions are affected by GHSA-ggpf-24jw-3fcw?
2 open source packages ship an affected version, including vllm.
| Package | Affected | Fixed in |
|---|---|---|
vllm PyPI | All versions | 0.8.0 |
vllm PyPI | All versions | 0.8.0 |
How do I fix GHSA-ggpf-24jw-3fcw?
Upgrade vllm to 0.8.0 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is GHSA-ggpf-24jw-3fcw being exploited?
There is no known exploitation of GHSA-ggpf-24jw-3fcw in the wild and no public exploit code.