# GHSA-ggpf-24jw-3fcw: CVE-2025-24357 Malicious model remote code execution fix bypass with PyTorch < 2.6.0

> Loading malicious models in vLLM with vulnerable PyTorch versions allows remote code execution via unsafe deserialization.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Apr 2025

## What is GHSA-ggpf-24jw-3fcw?

GHSA-ggpf-24jw-3fcw is an unsafe deserialization vulnerability in vllm, published on 23 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

## Description

https://github.com/vllm-project/vllm/security/advisories/GHSA-rh4j-5rhw-hr54 reported a vulnerability where loading a malicious model could result in code execution on the vllm host. The fix applied to specify `weights_only=True` to calls to `torch.load()` did not solve the problem prior to PyTorch 2.6.0.

PyTorch has issued a new CVE about this problem: https://github.com/advisories/GHSA-53q9-r3pm-6pq6

This means that versions of vLLM using PyTorch before 2.6.0 are vulnerable to this problem.
## Background Knowledge
When users install VLLM according to the official manual
![image](https://github.com/user-attachments/assets/d17e0bdb-26f2-46d6-adf6-0b17e5ddf5c7)

But the version of PyTorch is specified in the requirements. txt file
![image](https://github.com/user-attachments/assets/94aad622-ad6d-4741-b772-c342727c58c7)

So by default when the user install VLLM, it will install the PyTorch with version 2.5.1
![image](https://github.com/user-attachments/assets/04ff31b0-aad1-490a-963d-00fda91da47b)

In CVE-2025-24357, weights_only=True was used for patching, but we know this is not secure.
Because we found that using Weights_only=True in pyTorch before 2.5.1 was unsafe

Here, we use this interface to prove that it is not safe.
![image](https://github.com/user-attachments/assets/0d86efcd-2aad-42a2-8ac6-cc96b054c925)

## Fix
update PyTorch version to 2.6.0

## Credit
This vulnerability was found By Ji'an Zhou and Li'shuo Song

## Which versions are affected by GHSA-ggpf-24jw-3fcw?

2 open source packages ship an affected version, including vllm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.8.0 |
| `vllm` | PyPI | All versions | 0.8.0 |

## How do I fix GHSA-ggpf-24jw-3fcw?

Upgrade vllm to 0.8.0 or later.

## Is GHSA-ggpf-24jw-3fcw being exploited?

There is no known exploitation of GHSA-ggpf-24jw-3fcw in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-ggpf-24jw-3fcw and fix it if it is affected.

What it is: GHSA-ggpf-24jw-3fcw is an unsafe deserialization vulnerability in vllm, published on 23 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-ggpf-24jw-3fcw in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.8.0
- vllm (PyPI): affected all versions; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-ggpf-24jw-3fcw/ (Markdown: https://insights.sbomify.com/GHSA-ggpf-24jw-3fcw/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-ggpf-24jw-3fcw

---
From sbomify Insights: https://insights.sbomify.com/GHSA-ggpf-24jw-3fcw/
Summaries are generated and may contain mistakes; the official description above is the record.
