GHSA-ghc5-95c2-vwcv Auth0 Symfony SDK has Insufficient Entropy in Cookie Encryption
Insufficient entropy in cookie encryption allows attackers to brute-force keys and forge session cookies, leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-ghc5-95c2-vwcv?
GHSA-ghc5-95c2-vwcv is a vulnerability in auth0/symfony, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact
In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.
Am I Affected?
Consumers are affected if their application meets the following preconditions:
- It uses the Auth0 Symfony SDK, versions between 5.0.0 and 5.7.0
- Auth0 Symfony SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.
Resolution
Upgrade Auth0/symfony-auth0 to version 5.8.0 or greater.
Which versions are affected by GHSA-ghc5-95c2-vwcv?
2 open source packages ship an affected version, including auth0/symfony.
| Package | Affected | Fixed in |
|---|---|---|
auth0/symfony Packagist | From 5.0.0 | 5.8.0 |
auth0/symfony Packagist | From 5.0.0 | 5.8.0 |
How do I fix GHSA-ghc5-95c2-vwcv?
Upgrade auth0/symfony to 5.8.0 or later.
Is GHSA-ghc5-95c2-vwcv being exploited?
There is no known exploitation of GHSA-ghc5-95c2-vwcv in the wild and no public exploit code.