{"answers":{"affected":"2 open source packages ship an affected version, including auth0/symfony.","exploited":"There is no known exploitation of GHSA-ghc5-95c2-vwcv in the wild and no public exploit code.","fix":"Upgrade auth0/symfony to 5.8.0 or later.","what":"GHSA-ghc5-95c2-vwcv is a vulnerability in auth0/symfony, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-ghc5-95c2-vwcv and fix it if it is affected.\n\nWhat it is: GHSA-ghc5-95c2-vwcv is a vulnerability in auth0/symfony, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-ghc5-95c2-vwcv in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0/symfony (Packagist): affected from 5.0.0; fixed in 5.8.0\n- auth0/symfony (Packagist): affected from 5.0.0; fixed in 5.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-ghc5-95c2-vwcv/ (Markdown: https://insights.sbomify.com/GHSA-ghc5-95c2-vwcv/index.md)","id":"GHSA-ghc5-95c2-vwcv","markdown":"https://insights.sbomify.com/GHSA-ghc5-95c2-vwcv/index.md","name":"GHSA-ghc5-95c2-vwcv","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Auth0 Symfony SDK","requires_auth":"none","summary":"Insufficient entropy in cookie encryption allows attackers to brute-force keys and forge session cookies, leading to account takeover.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nIn applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.\n\n### Am I Affected?\nConsumers are affected if their application meets the following preconditions:\n- It uses the Auth0 Symfony SDK, versions between 5.0.0 and 5.7.0\n- Auth0 Symfony SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.\n\n### Resolution\nUpgrade Auth0/symfony-auth0 to version 5.8.0 or greater.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Auth0 Symfony SDK has Insufficient Entropy in Cookie Encryption","id":"GHSA-ghc5-95c2-vwcv","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.8.0"],"introduced":["5.0.0"],"last_affected":[],"package":"auth0/symfony","purl":null,"source":"GHSA-ghc5-95c2-vwcv"},{"ecosystem":"Packagist","fixed":["5.8.0"],"introduced":["5.0.0"],"last_affected":[],"package":"auth0/symfony","purl":"pkg:composer/auth0/symfony","source":"GHSA-ghc5-95c2-vwcv"}],"products":null,"published":"2026-04-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Insufficient entropy in cookie encryption allows attackers to brute-force keys and forge session cookies, leading to account takeover.","url":"https://insights.sbomify.com/GHSA-ghc5-95c2-vwcv/"}