# GHSA-ghc5-95c2-vwcv: Auth0 Symfony SDK has Insufficient Entropy in Cookie Encryption

> Insufficient entropy in cookie encryption allows attackers to brute-force keys and forge session cookies, leading to account takeover.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2026

## What is GHSA-ghc5-95c2-vwcv?

GHSA-ghc5-95c2-vwcv is a vulnerability in auth0/symfony, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Impact
In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.

### Am I Affected?
Consumers are affected if their application meets the following preconditions:
- It uses the Auth0 Symfony SDK, versions between 5.0.0 and 5.7.0
- Auth0 Symfony SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.

### Resolution
Upgrade Auth0/symfony-auth0 to version 5.8.0 or greater.

## Which versions are affected by GHSA-ghc5-95c2-vwcv?

2 open source packages ship an affected version, including auth0/symfony.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/symfony` | Packagist | From 5.0.0 | 5.8.0 |
| `auth0/symfony` | Packagist | From 5.0.0 | 5.8.0 |

## How do I fix GHSA-ghc5-95c2-vwcv?

Upgrade auth0/symfony to 5.8.0 or later.

## Is GHSA-ghc5-95c2-vwcv being exploited?

There is no known exploitation of GHSA-ghc5-95c2-vwcv in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-ghc5-95c2-vwcv and fix it if it is affected.

What it is: GHSA-ghc5-95c2-vwcv is a vulnerability in auth0/symfony, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-ghc5-95c2-vwcv in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/symfony (Packagist): affected from 5.0.0; fixed in 5.8.0
- auth0/symfony (Packagist): affected from 5.0.0; fixed in 5.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-ghc5-95c2-vwcv/ (Markdown: https://insights.sbomify.com/GHSA-ghc5-95c2-vwcv/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-ghc5-95c2-vwcv

---
From sbomify Insights: https://insights.sbomify.com/GHSA-ghc5-95c2-vwcv/
Summaries are generated and may contain mistakes; the official description above is the record.
