{"answers":{"affected":"2 open source packages ship an affected version, including @vendure/admin-ui-plugin.","exploited":"There is no known exploitation of GHSA-gm68-572p-q28r in the wild and no public exploit code.","fix":"Upgrade @vendure/admin-ui-plugin to 2.0.3 or later.","what":"GHSA-gm68-572p-q28r is a cross-site scripting vulnerability in @vendure/admin-ui-plugin, published on 6 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-gm68-572p-q28r and fix it if it is affected.\n\nWhat it is: GHSA-gm68-572p-q28r is a cross-site scripting vulnerability in @vendure/admin-ui-plugin, published on 6 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-gm68-572p-q28r in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @vendure/admin-ui-plugin (npm): affected all versions; fixed in 2.0.3\n- @vendure/admin-ui-plugin (npm): affected all versions; fixed in 2.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-gm68-572p-q28r/ (Markdown: https://insights.sbomify.com/GHSA-gm68-572p-q28r/index.md)","id":"GHSA-gm68-572p-q28r","markdown":"https://insights.sbomify.com/GHSA-gm68-572p-q28r/index.md","name":"GHSA-gm68-572p-q28r","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vendure admin UI plugin","requires_auth":"low_privilege","summary":"Authenticated users can inject arbitrary HTML into description fields, leading to XSS and privilege escalation when other users view the page.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nVendure provides an authorization system with different levels of privileges. For example, an administrator cannot create another administrator.\n\nIn the admin UI, there are a couple of places with description inputs, such as inventory/collection catalog, shipping methods, promotions, and more.\n\nWhile the WYSIWYG editor allows limited customization, altering the request data (not in the ui) saves and returns arbitrary HTML with no sanitization. Causing an XSS when viewing the page.\n\nThe impact of this XSS is privilege escalation. A user that can write any type of description can trigger the attack. Then any other user that visits the vulnerable page is prone to arbitrary Javascript code execution, giving the attacker ability to execute actions on behalf of this user.\n\n### Patches\nin progress\n\n### Workarounds\n_Is there a way for users to fix or remediate the vulnerability without upgrading?_\n\n### References\n_Are there any links users can visit to find out more?_","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"@vendure/admin-ui-plugin authenticated Cross-site Scripting vulnerability","id":"GHSA-gm68-572p-q28r","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.0.3"],"introduced":["0"],"last_affected":[],"package":"@vendure/admin-ui-plugin","purl":null,"source":"GHSA-gm68-572p-q28r"},{"ecosystem":"npm","fixed":["2.0.3"],"introduced":["0"],"last_affected":[],"package":"@vendure/admin-ui-plugin","purl":"pkg:npm/%40vendure/admin-ui-plugin","source":"GHSA-gm68-572p-q28r"}],"products":null,"published":"2023-07-06","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Authenticated users can inject arbitrary HTML into description fields, leading to XSS and privilege escalation when other users view the page.","url":"https://insights.sbomify.com/GHSA-gm68-572p-q28r/"}