GHSA-gpv5-rp6w-58r8 Remote code execution vulnerability in dependency System.Drawing.Common
Remote code execution via vulnerable System.Drawing.Common dependency in Akka.NET; upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not stated
- Attackable
- Over the internet
- Victim action needed
- Not stated
- Fix
- Available
What is GHSA-gpv5-rp6w-58r8?
GHSA-gpv5-rp6w-58r8 is a code injection vulnerability in Akka, published on 22 Nov 2022. It can be exploited over the network.
Official description
Impact
The core Akka module depended on an old System.Configuration.ConfigurationManager version 4.7.0 which transitively depends on System.Common.Drawing v4.7.0. The System.Common.Drawing v4.7.0 is affected by a remote code execution vulnerability https://github.com/advisories/GHSA-ghhp-997w-qr28.
The real-world impact of this should be low, but users should be advised to upgrade to later versions of Akka.NET.
Patches
Has the problem been patched? What versions should users upgrade to?
This issue is resolved in Akka.NET v1.4.46 and Akka.NET v1.5.0-alpha3.
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
You might be able to explicitly reference System.Configuration.ConfigurationManager's NuGet package and upgrade to 6.0.1 or later without upgrading Akka.NET, but it's probably best to upgrade Akka.NET itself.
References
Are there any links users can visit to find out more?
Original issue: https://github.com/akkadotnet/akka.net/issues/6226 MSFT advisory: https://github.com/advisories/GHSA-ghhp-997w-qr28
For more information
If you have any questions or comments about this advisory:
- Open an issue in the Akka.NET repository
- Contact us on the Akka.NET Discord
Which versions are affected by GHSA-gpv5-rp6w-58r8?
4 open source packages ship an affected version, including Akka.
| Package | Affected | Fixed in |
|---|---|---|
Akka NuGet | All versions | 1.4.46 |
Akka NuGet | All versions | 1.4.46 |
Akka NuGet | From 1.5.0-alpha1 | 1.5.0-alpha3 |
Akka NuGet | From 1.5.0-alpha1 | 1.5.0-alpha3 |
How do I fix GHSA-gpv5-rp6w-58r8?
Upgrade Akka to a fixed version for your release line: 1.4.46 or 1.5.0-alpha3.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is GHSA-gpv5-rp6w-58r8 being exploited?
There is no known exploitation of GHSA-gpv5-rp6w-58r8 in the wild and no public exploit code.