{"answers":{"affected":"4 open source packages ship an affected version, including Akka.","exploited":"There is no known exploitation of GHSA-gpv5-rp6w-58r8 in the wild and no public exploit code.","fix":"Upgrade Akka to a fixed version for your release line: 1.4.46 or 1.5.0-alpha3.","what":"GHSA-gpv5-rp6w-58r8 is a code injection vulnerability in Akka, published on 22 Nov 2022. It can be exploited over the network."},"fix_prompt":"Check this codebase for GHSA-gpv5-rp6w-58r8 and fix it if it is affected.\n\nWhat it is: GHSA-gpv5-rp6w-58r8 is a code injection vulnerability in Akka, published on 22 Nov 2022. It can be exploited over the network.\nExploitation: There is no known exploitation of GHSA-gpv5-rp6w-58r8 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Akka (NuGet): affected all versions; fixed in 1.4.46\n- Akka (NuGet): affected all versions; fixed in 1.4.46\n- Akka (NuGet): affected from 1.5.0-alpha1; fixed in 1.5.0-alpha3\n- Akka (NuGet): affected from 1.5.0-alpha1; fixed in 1.5.0-alpha3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-gpv5-rp6w-58r8/ (Markdown: https://insights.sbomify.com/GHSA-gpv5-rp6w-58r8/index.md)","id":"GHSA-gpv5-rp6w-58r8","markdown":"https://insights.sbomify.com/GHSA-gpv5-rp6w-58r8/index.md","name":"GHSA-gpv5-rp6w-58r8","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Akka.NET library","requires_auth":"unknown","summary":"Remote code execution via vulnerable System.Drawing.Common dependency in Akka.NET; upgrade to patched versions.","user_interaction":"unknown","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nThe core Akka module depended on an old System.Configuration.ConfigurationManager version 4.7.0 which transitively depends on System.Common.Drawing v4.7.0. The System.Common.Drawing v4.7.0 is affected by a remote code execution vulnerability https://github.com/advisories/GHSA-ghhp-997w-qr28.\n\nThe real-world impact of this should be low, but users should be advised to upgrade to later versions of Akka.NET.\n\n### Patches\n_Has the problem been patched? What versions should users upgrade to?_\n\nThis issue is resolved in Akka.NET v1.4.46 and Akka.NET v1.5.0-alpha3.\n\n### Workarounds\n_Is there a way for users to fix or remediate the vulnerability without upgrading?_\n\nYou might be able to explicitly reference System.Configuration.ConfigurationManager's NuGet package and upgrade to 6.0.1 or later without upgrading Akka.NET, but it's probably best to upgrade Akka.NET itself.\n\n### References\n_Are there any links users can visit to find out more?_\n\nOriginal issue: https://github.com/akkadotnet/akka.net/issues/6226\nMSFT advisory: https://github.com/advisories/GHSA-ghhp-997w-qr28\n\n### For more information\nIf you have any questions or comments about this advisory:\n\n* Open an issue in [the Akka.NET repository](https://github.com/akkadotnet/akka.net/issues/new)\n* Contact us on [the Akka.NET Discord](https://discord.gg/GSCfPwhbWP)","ecosystems":["NuGet"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Remote code execution vulnerability in dependency System.Drawing.Common","id":"GHSA-gpv5-rp6w-58r8","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"NuGet","fixed":["1.4.46"],"introduced":["0"],"last_affected":[],"package":"Akka","purl":null,"source":"GHSA-gpv5-rp6w-58r8"},{"ecosystem":"NuGet","fixed":["1.4.46"],"introduced":["0"],"last_affected":[],"package":"Akka","purl":"pkg:nuget/Akka","source":"GHSA-gpv5-rp6w-58r8"},{"ecosystem":"NuGet","fixed":["1.5.0-alpha3"],"introduced":["1.5.0-alpha1"],"last_affected":[],"package":"Akka","purl":null,"source":"GHSA-gpv5-rp6w-58r8"},{"ecosystem":"NuGet","fixed":["1.5.0-alpha3"],"introduced":["1.5.0-alpha1"],"last_affected":[],"package":"Akka","purl":"pkg:nuget/Akka","source":"GHSA-gpv5-rp6w-58r8"}],"products":null,"published":"2022-11-22","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Remote code execution via vulnerable System.Drawing.Common dependency in Akka.NET; upgrade to patched versions.","url":"https://insights.sbomify.com/GHSA-gpv5-rp6w-58r8/"}