# GHSA-gpv5-rp6w-58r8: Remote code execution vulnerability in dependency System.Drawing.Common

> Remote code execution via vulnerable System.Drawing.Common dependency in Akka.NET; upgrade to patched versions.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 22 Nov 2022

## What is GHSA-gpv5-rp6w-58r8?

GHSA-gpv5-rp6w-58r8 is a code injection vulnerability in Akka, published on 22 Nov 2022. It can be exploited over the network.

### Official description

### Impact

The core Akka module depended on an old System.Configuration.ConfigurationManager version 4.7.0 which transitively depends on System.Common.Drawing v4.7.0. The System.Common.Drawing v4.7.0 is affected by a remote code execution vulnerability https://github.com/advisories/GHSA-ghhp-997w-qr28.

The real-world impact of this should be low, but users should be advised to upgrade to later versions of Akka.NET.

### Patches
_Has the problem been patched? What versions should users upgrade to?_

This issue is resolved in Akka.NET v1.4.46 and Akka.NET v1.5.0-alpha3.

### Workarounds
_Is there a way for users to fix or remediate the vulnerability without upgrading?_

You might be able to explicitly reference System.Configuration.ConfigurationManager's NuGet package and upgrade to 6.0.1 or later without upgrading Akka.NET, but it's probably best to upgrade Akka.NET itself.

### References
_Are there any links users can visit to find out more?_

Original issue: https://github.com/akkadotnet/akka.net/issues/6226
MSFT advisory: https://github.com/advisories/GHSA-ghhp-997w-qr28

### For more information
If you have any questions or comments about this advisory:

* Open an issue in [the Akka.NET repository](https://github.com/akkadotnet/akka.net/issues/new)
* Contact us on [the Akka.NET Discord](https://discord.gg/GSCfPwhbWP)

## Which versions are affected by GHSA-gpv5-rp6w-58r8?

4 open source packages ship an affected version, including Akka.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Akka` | NuGet | All versions | 1.4.46 |
| `Akka` | NuGet | All versions | 1.4.46 |
| `Akka` | NuGet | From 1.5.0-alpha1 | 1.5.0-alpha3 |
| `Akka` | NuGet | From 1.5.0-alpha1 | 1.5.0-alpha3 |

## How do I fix GHSA-gpv5-rp6w-58r8?

Upgrade Akka to a fixed version for your release line: 1.4.46 or 1.5.0-alpha3.

## Is GHSA-gpv5-rp6w-58r8 being exploited?

There is no known exploitation of GHSA-gpv5-rp6w-58r8 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-gpv5-rp6w-58r8 and fix it if it is affected.

What it is: GHSA-gpv5-rp6w-58r8 is a code injection vulnerability in Akka, published on 22 Nov 2022. It can be exploited over the network.
Exploitation: There is no known exploitation of GHSA-gpv5-rp6w-58r8 in the wild and no public exploit code.

Affected packages and fixed versions:
- Akka (NuGet): affected all versions; fixed in 1.4.46
- Akka (NuGet): affected all versions; fixed in 1.4.46
- Akka (NuGet): affected from 1.5.0-alpha1; fixed in 1.5.0-alpha3
- Akka (NuGet): affected from 1.5.0-alpha1; fixed in 1.5.0-alpha3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-gpv5-rp6w-58r8/ (Markdown: https://insights.sbomify.com/GHSA-gpv5-rp6w-58r8/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-gpv5-rp6w-58r8

---
From sbomify Insights: https://insights.sbomify.com/GHSA-gpv5-rp6w-58r8/
Summaries are generated and may contain mistakes; the official description above is the record.
